UCS 5.0 - cannot increase owncloud 10.7 default upload limit

Hello - Well, I got it running but now cannot get the upload limit more than the default 2mb on owncloud 10.7 - UCS 5.0 with php 7.3. Any advice would be greatly appreciated! I tried to sudo nano /etc/php/7.3/apache2/php.ini but nothing changes - I am not sure where to go to change it now. Thanks

Have you looked at the php.ini inside the docker container?


univention-app shell owncloud

Then check the config there.

Thanks for response! I can get in to the docker but am not sure of the path to find that ini - I did try this but still have same issue in there - is there another htaccess file in the docker container?

I was able to use vim and added the lines to the php.config but still no change - any ideas greatly appreciated! I thought that would do it


Check the same path you mentioned in your original post, just inside the container.

Hey thanks so much for the answer! I think I am close! I am pretty good with nano, but just started with vim - does this error mean it is not the file being used by owncloud, or just that it doesnt exist and I need to create it? (E212:Cant open file for writing) or will it break owncloud if I sudo it and create it anyway? I do know this file exists in my univention system, I can see it in WinSCP, but there is also a php folder for 7.0, which I dont think owncloud X supports any longer, so it must be using php 7.3. Again, thanks for your help, it is hard to get any response on here since 5.0 was released. I myself have been battling issue after issue, with this being one of the last ones to get it running normal again after the upgrade…


I don’t use owncloud on my UCS system. I use nextcloud. I would guess they are very similar, but I don’t know for sure.

Once you’re in the container, just look for whatever php.ini file owncloud uses.

In nextcloud I just cd’d my way down the path and the php.ini was in almost exactly the same path as your first post. The only difference was that the php version was 7.4 IIRC.

Also, I haven’t checked the owncloud docs. If you’re not sure what file you should be editing, I would recommend consulting the owncloud docs first. You could be wasting a bunch of time trying to configure the wrong thing and might end up having to go back and revert your changes. If people are uploading big files, you might also have to configure some temp storage space as well. I don’t think very many of these php based uploaders can stream the files directly to disk and have to store the post data in a tmp file and then copy it to it’s final destination. It can get messy with large uploads pretty easily if you don’t have plenty of space to work with.

Awesome! thanks for the great pointers! Wish there was an easier way to figure out which php owncloud is actually using - i have changed 6-8 now and still nto changing my max upload - I have ran univention owncloud since 2014 or so and was able to immediately change the parameters before but cannot find it for anything in Univention 5, owncloud 10.7. It is useless with a 2mb upload limit, i know that much!

I loaded up owncloud on a test VM for UCS 5. I uploaded a 45MB file without having to change anything. I checked the /etc/php/7.4/apache2/php.ini file and it was set to 2MB, but that obviously was not affecting it’s operation, so there is something else going on that is not in line with the configuration as shipped.

ok. Thank you, very helpful. I had read there was supposed to be the option to increase file uploads inside the GUI interface of owncloud in the Admin section, but I cant find anything there or in the UMC configuration. I am wondering if maybe the tmp directory used for uploads is running into issues with permissions perhaps? Do you happen to know what that path is defined as in your ini? Thank you - I did find this from docker info command:


WARNING: No swap limit support
WARNING: the overlay storage-driver is deprecated, and will be removed in a future release.
seems relevant maybe?

My storage driver shows overlay2. Other than that everything looks the same.

Did you check


The owncloud docs mention this file and it is present on my clean install and has some relevant settings in it. The .htaccess there also has what looks to be duplicate settings. It looks like which one it uses may depend on whether or not php-fpm is in use based on the docs. I’m not sure which file actually matters in the default install.

Thank you! Yep, tried that one too. Its bizarre, everything runs great just cant change upload size anywhere… Thanks for your answer, will have to try uninstalling and reinstalling I suppose! Do you know if the apt-get remove --purge owncloud will do a thorough enough job to give a clean state?


I think you need to go through the app center. Owncloud is an app so it should be installed as a docker container not a package unless I am missing something.

Take care:
As far as I know, the database will remain after removal and is not acceable after re-install caused by annother database password.
Store the config.php before removal - it contains the database password “secret = …”.

Starting from here I cannot help anymore.

Thanks for your answers! At this ppoint have tried everything, something appears to be irretrievably broken in this installation after the UCS 5.0 Upgrade. I should have ran far far away instead. I havent seen any UCS staff at all since the update…

I tried to reproduce the issue in a fresh UCS 5.0 installation and ownCloud. I was able to upload files larger than 50MB. I recommend to check all your manual changes and compare them with a fresh installation.

Please also note that this is a community forum for UCS, which should be understood as free support without SLAs - if you need professional help please get in touch whith Univention to get a subscription. Further more this might be a ownCloud specific issue. The ownCloud App is provided by ownCloud for UCS, if you need ownCloud specific assistance please also post in ownCloud specific forums.

Thank you. it turned out I had to change the temp directory in the owncloud docker php and .user.ini and then also run occ:scan files --all and it started uploading large files agian.