UCS 4.4 installation on XCP-ng

Hello,

I have a very strange problem during installation. Just a bit of background before I describe the problem.
I have UCS4.4 VM running absolutely fine on an ESXi5.5 server and I want to migrate it to XCP-ng because it’s free. I installed an XCP-ng server on a separate machine on which I’m already running 3 VMs without any problem.

Now to the problem. I’m installing UCS 4.4 on XCP-ng using the iso image. The installation starts fine until a point where it display the following message. It stays forever.

image
It took me a while to figure it out, but the problems seems to be with the DNS resolution. Apparently, it can’t resolve domains. I can ping IPs but not domains. I found that out by installing again, this time by importing an ova image. I tried 2, VirtualBox and ESX, same problem. It tried dynamic IP, static IP, plenty of DNS servers, nothing helps. All my other VMs work fine and resolve DNS without any problem. I even tried to export UCS from my ESXi server and import it to XCP-ng, same problem.

Any help or direction you can provide would be greatly appreciated.

Thanks,

Laurent

Hi,

I managed to bypass the installation problem by pointing the DNS to my router IP, but I still have a diagnostics warning “nameserver(s) are not responsive”. Something is wrong with bind and I can’t figure how to fix it. Help will be appreciated.

Thanks,

Laurent

Hi,
i run my UCS in XEN (xl stack) without any problems. Since you can ping other hosts that’s not a topic to virtualization.

Configure your DNS according to your network setup in the UCS Configuration Registry:

ucr set dns/forwarder1 = ‘IP of your Router’
ucr set nameserver1 = ‘IP of your internal DNS’

See UCS Handbook for more details.