UCS 4.4 eratta 147 not returning group names in bash

ldap
bash
ucs-4-4

#1

Running the command below no longer returns the list of groups a user belongs to.

id -Gnr $USER

I should see groups like “All Staff” and “HS Faculty” but instead it returns this

1003082694 everyone netaccounts com.apple.sharepoint.group.2 _lpadmin _lpoperator com.apple.sharepoint.group.1

I have tried to remove and re-add the groups. Is there an alternate search method I should be using?


#2

[UPDATE] It seems to work correctly under 10.12. And before I restored the UCS from a backup it worked under 10.13 and 10.14.

It only shows the incorrect groups when logged in and I run the id -Gnr $USER under 10.13 and 10.14 and when I check another user on 10.13 or 10.14 bash command. It works correctly and shows the active directory groups like “Group\DOMAIN”. This is really screwy.

groups username

But if I check

groups myusername

It too returns the weird screwy groups like id -Gnr $USER


#3

So I found an alternative method (for Macs)

dscl "/Active Directory/DOMAIN/All Domains" read /Users/$USER memberOf