UCS 4.3 ipv6 gateway problem

ipv6
ucs-4-3

#1

hi,
I got a problem with setting up ipv6 on a clean installed UCS 4.3 installation.
After adding the ipv6-address, suffix and the ipv6-gateway ipv6 is working. after a reboot ipv6 stopped working.
it seems the ipv6 gateway isn’t added as a default route after a reboot.
trying to set it manually isn’t working either:

ip -6 route add default via fe80::1
RTNETLINK answers: Invalid argument

ucr search ipv6/gateway shows the right gateway.
ipv6-dns resolution still works, it is just the route missing…
even removing and adding the ipv6 address and/or the gateway won’t work.
just manually adding the gateway to /etc/network/interfaces and reloading the networking service helps.

I am a bit puzzled. Am I doing something wrong or is it a bug?

thank you!


#2

Hi!

It looks like the interface name is missing at the link local address. Link local addresses are only valid on one interface, which is why the link local addresses have to be always specified with an interface (e.g. fe80::1234:5678:1324:5768%eth0). So the UCR variable has to be set like this:
ucr set ipv6/gateway=fe80::1%eth0

But yes, there is currently a problem with link local addresses (fe80:: ) and the gateway configuration.
If there is no problem for you in configuring static link local addresses, you can use the following (only roughly tested) workaround:

ucr set interfaces/eth0/ipv6/dummy1/address=LINKLOCALADDR \
        interfaces/eth0/ipv6/dummy1/prefix=64 \
        ipv6/gateway=fe80::1%eth0

LINKLOCALADDR has to be replaced with an unused link local address. You can use, for example, the one currently configured at your interface. Run ip -6 a to get a list of all configured IPv6 addresses at your network interfaces. Also, eth0 may have to be adopted to your affected network interface. dummy1 is a unique placeholder that can be chosen at will (unless it does not interfere with other UCR variable settings).

Please note that you may have problems again in setting the IPv6 gateway if the automatic DAD (Duplicate Address Detection) fails. So for this workaround you have to make sure that the configured link local address is not used twice on the configured interface.

Best regards,

Sönke


#3

hi!

ucr set ipv6/gateway=fe80::1%ens3

(ens3 is my main interface) just worked!
thank you, easy solution :smile:

Best Regards