UCS 4.3-2 install php 7.1

repository
php

#1

Hi,

For a Nextcloud app i need to install php 7.1 or higher and today i tried my best but couldnt install it.

when i try to import the repository in the web-console, it shows, that UCS can’t connect to it.
I also tried to add the repo with ssh but it still wont install.

What is the best way to install php 7.1 on the system?

thx for your help


#2

Hi,

as far as I know the Nextcloud app is “dockerzied”, isn’t it? So if you really want to break the stuff Nextcloud and Univention have set up I would strongly suggest to install php 7.1 inside of the docker container. Thus, only Nextcloud would be likely to fail instead of breaking the UCS system at all.

To do so you might use the command " univention-app shell nextcloud " to get into the container.

/CV


#3

Just to reassure @Christian_Voelker: Yes, the Nextcloud App is in a Docker Container which ships its own version of PHP. The Nextcloud Docker Container is based on Ubuntu - that might be relevant. However, the App for version 14 of Nextcloud will be based on Ubuntu 18.04 (https://github.com/nextcloud/univention-app/pull/75) which ships PHP 7.2, if I recall correctly. So maybe just wait a couple of days?