UCS 4.2-2 update issue when running "apt list"

ucs-4-2
upgrade

#1

My current version is:

UCS Version
4.2-2 errata189 (Lesum)
UMC Version
9.0.80-70A~4.2.0.201709191414

Please see the list below when I run “apt list --upgradable”. It contains a series of “unknown” entries which is very worrying. Should I ignore this?.
The problem occurred as I ran this command in the process of solving SAML certificate error (see Error checking SAML ucs-sso certificate). I havent yet recieved a reply to this on this forum.

Listing...
python-univention/**unknown** 10.0.4-4A~4.2.0.201710061505 all [upgradable from: 10.0.4-3A~4.2.0.201707200928]
python-univention-directory-manager/**unknown** 12.0.18-11A~4.2.0.201710091208 all [upgradable from: 12.0.18-9A~4.2.0.201708151221]
python-univention-directory-manager-cli/**unknown** 12.0.18-11A~4.2.0.201710091208 all [upgradable from: 12.0.18-9A~4.2.0.201708151221]
python-univention-lib/unknown 6.0.9-18A~4.2.0.201710021703 all [upgradable from: 6.0.9-12A~4.2.0.201709111501]
python-univention-management-console/**unknown** 9.0.80-76A~4.2.0.201710051802 all [upgradable from: 9.0.80-70A~4.2.0.201709191414]
shell-univention-lib/unknown 6.0.9-18A~4.2.0.201710021703 all [upgradable from: 6.0.9-12A~4.2.0.201709111501]
univention-directory-manager-tools/**unknown** 12.0.18-11A~4.2.0.201710091208 all [upgradable from: 12.0.18-9A~4.2.0.201708151221]
univention-errata-level/**unknown** 4.2.2-196 all [upgradable from: 4.2.2-189]
univention-ldap-acl-master/**unknown** 13.0.7-20A~4.2.0.201709291539 all [upgradable from: 13.0.7-19A~4.2.0.201709051324]
univention-ldap-client/**unknown** 13.0.7-20A~4.2.0.201709291539 all [upgradable from: 13.0.7-19A~4.2.0.201709051324]
univention-ldap-config/**unknown** 13.0.7-20A~4.2.0.201709291539 all [upgradable from: 13.0.7-19A~4.2.0.201709051324]
univention-ldap-server/**unknown** 13.0.7-20A~4.2.0.201709291539 all [upgradable from: 13.0.7-19A~4.2.0.201709051324]
univention-management-console/**unknown** 9.0.80-76A~4.2.0.201710051802 all [upgradable from: 9.0.80-70A~4.2.0.201709191414]
univention-management-console-frontend/**unknown** 9.0.80-76A~4.2.0.201710051802 all [upgradable from: 9.0.80-70A~4.2.0.201709191414]
univention-management-console-login/**unknown** 9.0.80-76A~4.2.0.201710051802 all [upgradable from: 9.0.80-70A~4.2.0.201709191414]
univention-management-console-server/**unknown** 9.0.80-76A~4.2.0.201710051802 all [upgradable from: 9.0.80-70A~4.2.0.201709191414]
univention-management-console-web-server/**unknown** 9.0.80-76A~4.2.0.201710051802 all [upgradable from: 9.0.80-70A~4.2.0.201709191414]
univention-nagios-client/**unknown** 10.1.1-6A~4.2.0.201710021715 amd64 [upgradable from: 10.0.1-7A~4.2.0.201708111206]
univention-nagios-common/**unknown** 10.1.1-6A~4.2.0.201710021715 amd64 [upgradable from: 10.0.1-7A~4.2.0.201708111206]
univention-nagios-server/**unknown** 10.1.1-6A~4.2.0.201710021715 amd64 [upgradable from: 10.0.1-7A~4.2.0.201708111206]
univention-web-js/**unknown** 1.0.42-48A~4.2.0.201710091716 all [upgradable from: 1.0.42-45A~4.2.0.201709181547]
univention-web-style/**unknown** 1.0.42-48A~4.2.0.201710091716 all [upgradable from: 1.0.42-45A~4.2.0.201709181547]


#2

I do not think this is an issue. Please be advised: Only use univention tools to install, upgrade or remove packages, or problems will occur. Only use apt or apt-get directly if advised by our support to do so.

The univention tools you want to use are

univention-install <packages>
univention-remove <packages>
univention-upgrade

The alternative is to install, remove packages and upgrade your UCS system via the UMC


#3

Thank you. Will stick to that.

I was just experimenting with various suggestions/google-answers to get the SAML SSO certificate error fixed.


#4

Hey,

That’s one thing you don’t have to worry about. What apt usually lists here is the release a package comes from if that release is known. For Ubuntu, for example, the output might be zsh/xenial,now 5.1.1-1ubuntu2 amd64 [installed]. This requires that the APT repository be set up in a specific way.

A lot of APT repositories use a somewhat simpler setup without real release information. For such repositories apt simply says unknown. Univention’s APT repositories are set up in that simpler mode; therefore all of their packages shown unknown as the release.

This is a technical detail and absolutely nothing to worry about.

Kind regards,
mosu