UCS 4.2.1 named diff.c:185 error

dns
ucs-4-2

#1

Hello,

we updated our UCS 4.1.4 to 4.2.1 yesterday. The update was successfull but we’re facing some troubles with DNS.

Aug 22 08:06:33 companydc named[1293]: samba_dlz: subtracted rdataset mac-112.mycompany.com 'mac-112.mycompany.local.#011900#011IN#011A#01110.10.23.235'
Aug 22 08:06:33 companydc named[1293]: diff.c:185: unexpected error:
Aug 22 08:06:33 companydc named[1293]: unexpected non-minimal diff

Above you can see some ouput of the syslog. This 3 lines appear a million times for some of our clients until the rsyslogd begins to drop the messages due to rate-limiting.
When too many clients are online the named service takes up to 100% CPU and the DNS stops working for some minutes until the named service turns back to normal state again.
Logins aren’t working aswell in this few minutes.

When restoring back to our UCS 4.1.4 via backup this error disappears. it seems to be an issue with the update.

Anyone had some similar problems or can help us out?

best regards
Pascalis


#2

Ok we’ve solved the problem.
We deleted the client objects in our DNS zone which seems to have solved this problem.

EDIT: we also had to change the dns/backend to ldap

best regards.