UCS 4.1 als VirtualBox Guest: VBoxLinuxAdditions hinzufügen

german

#1

Hallo,

ich bin gerade dabei, den Domänentransfer zu testen. Darum habe ich einen Windows 7 Recher mit VirtualBox dauf installiert und als Gast die neue “UCS Domäne”.

Warum mache ich das? Weil ich ein paar komplexe Test von Abläufen ausprobieren muss und dann gerne bei einem Misserfolg oder Abbruch, die UCS-Domäne einfache durch den gesetzte Snapshoot zurücksetzen kann. Wie gesagt, ist nur für die Test, im Echtbetrieb läuft die Sache dann auf richtigen Maschienen

Jetzt habe ich das Problem, das ich die GuestAdditions nicht installiert bekomme.Folgende Seiten waren meine Infoquellen: https://virtualboxes.org/doc/installing-guest-additions-on-debian/ und http://unixnme.blogspot.de/2016/11/how-to-install-virtualbox-guest.html

univention-install build-essential module-assistant
mount /media/cdrom
sh /media/cdrom/VBoxLinuxAdditions.run[/code]

Das bringt die Fehlermeldung:
[code]vboxadd.sh: Building Guest Additions kernel modules.
Failed to set up service vboxadd, please check the log file
/var/log/VBoxGuestAdditions.log for details.

Im Log finde ich dann folgenden Hinweis:

vboxadd.sh: failed: Look at /var/log/vboxadd-install.log to find out what went wrong. vboxadd.sh: failed: Please check that you have gcc, make, the header files for your Linux kernel and possibly perl installed..

Also hab ich folgendes versucht:

univention-install gcc make linux-hearders-$(uname -r)

Was wiederum zu dem Fehler führte:

E: Paket linux-hearders-4.1.0-ucs207-amd64 kann nicht gefunden werden. E: Mittels regulärem Ausdruck »linux-hearders-4.1.0-ucs207-amd64« konnte kein Paket gefunden werden.

Meine Frage: Was kann ich nun tun, damit ich die GuestAdditions draufbekommen, weil ich sonst nicht die volle Netwerkkartenleistung bekomme und das Übertragen von den Datenbanken und Dateien dann “ewig” dauert (eine DB ist 1TB groß und braucht 28 Stunden zum schreiben)

Vielen Dank für die Hinweise

LG
Michael


Display settings
#2

Hallo Michael,

Ich denke mal, wenn man statt ‘hearders’ das Paket ‘headers’ nennt, sollte man schon einen Schritt weiter kommen.

viele Grüße
Frank Greif


#3

Stimmt :wink: - Manchmal kann das Leben so einfach sein

Danke für den Tipp - jetzt läuft es und ich kann meine Tests weiter durchführen