UCS 3.2 Zarafa 7.1.8-1

german

#1

Hallo,

habe Zarafa über das App-Center installiert. Der erste Vesand und empfang von Mails hat funktioniert. Danach geht nichts mehr.
Relayhost habe ich eingetragen. Wenn ich über die Konsole via mail Komando versende, geht die Mail raus. Über Zarafa WebApp klappt es nicht. Laut log versucht der Server sich mit der lokalen Domäne bei dem SMTP-Server anzumelden. Hier ein auszug aus dem Log:

Feb 25 16:05:10 ucs postfix/master[28932]: daemon started -- version 2.7.1, configuration /etc/postfix Feb 25 16:15:10 ucs postfix/qmgr[28934]: 9DB2B14C1E91: from=<hr@ldt.home>, size=1912, nrcpt=1 (queue active) Feb 25 16:15:11 ucs postfix/smtp[29490]: certificate verification failed for smtp.1und1.de[212.227.15.167]:25: untrusted issuer /C=ZA/ST=Western Cape/L=Cape Town/O=Thawte Consulting cc/OU=Certification Services Division/CN=Thawte Premium Server CA/emailAddress=premium-server@thawte.com Feb 25 16:15:11 ucs postfix/smtp[29490]: 9DB2B14C1E91: host smtp.1und1.de[212.227.15.167] said: 421 invalid sender domain 'ldt.home' (misconfigured dns?) http://postmaster.1and1.com/error-messages/#invalidsenderdomain (in reply to MAIL FROM command) Feb 25 16:15:13 ucs postfix/smtp[29490]: certificate verification failed for smtp.1und1.de[212.227.15.183]:25: untrusted issuer /C=ZA/ST=Western Cape/L=Cape Town/O=Thawte Consulting cc/OU=Certification Services Division/CN=Thawte Premium Server CA/emailAddress=premium-server@thawte.com Feb 25 16:15:14 ucs postfix/smtp[29490]: 9DB2B14C1E91: to=<hradek@t-online.de>, relay=smtp.1und1.de[212.227.15.183]:25, delay=68490, delays=68487/0.04/2.9/0.23, dsn=4.0.0, status=deferred (host smtp.1und1.de[212.227.15.183] said: 421 invalid sender domain 'ldt.home' (misconfigured dns?) http://postmaster.1and1.com/error-messages/#invalidsenderdomain (in reply to MAIL FROM command)) Feb 25 16:23:46 ucs fetchmail[27378]: 3 messages for zmail@radek-ldt.de at pop.1und1.de (12392 octets). Feb 25 16:23:46 ucs fetchmail[27378]: reading message zmail@radek-ldt.de@pop.1und1.de:1 of 3 (4305 octets) (log message incomplete) Feb 25 16:23:46 ucs fetchmail[27378]: Connection errors for this poll:#012name 0: connection to localhost:smtp [::1/25] failed: Connection refused.#012name 1: connection to localhost:smtp [127.0.0.1/25] failed: Connection refused. Feb 25 16:23:46 ucs fetchmail[27378]: SMTP connect to localhost failed Feb 25 16:23:46 ucs fetchmail[27378]: SMTP transaction error while fetching from zmail@radek-ldt.de@pop.1und1.de and delivering to SMTP host localhost Feb 25 16:23:46 ucs fetchmail[27378]: Query status=10 (SMTP)

Wie in dem Log auch zu erkennen ist, kann fetchmail die Mails lokal nicht zustellen.

Wer kann mir da weiterhelfen ?
Danke !


#2

Hallo hradek,

Die Mailadresse des Absenders ist falsch, eine Domain “ldt.home” gibt es nicht außerhalb Ihres Unternehmensnetzes. Der Empfängerhost (smtp.1und1.de) schaut im öffentlichen DNS nach und sagt, einen solchen Absender kann es nicht geben. Da sollten Sie zuerst mal in den Eigenschaften des Nutzers “hr” schauen, auf der Seite “Allgemein” steht die “primäre Mailadresse”. Wenn dort eine korrekte Adresse drin steht (z.B. "hr@radek-ldt.de"), müßte man die Konfigurationen durchsehen, wo sich die verkehrte Domain eingeschlichen hat…

Ist es der gleiche Host, auf dem Fetchmail läuft, auf dem die Mails auch zugestellt werden sollen?

[ul]
[li] wenn ja: dann fragt sich, warum auf Port 25 niemand hört. Da sollte ein Postfix lauschen. Erste Anlaufstelle wäre die Datei /var/log/mail.log, dort müßte man doch sehen, warum Postfix nicht hört.[/li]
[li] wenn nein: dann sollte man dem Fetchmail sagen, wohin es wirklich ausliefern soll (anstatt nach ‘localhost’). Der Parameter hieße dann “smtphost”.[/li][/ul]

Hoffe es hilft bei der Fehlersuche.

viele Grüße,
Frank Greif.


#3

Hallo greif,

die primäre Mailadresse war die falsche, Ich habe dies geändert und diese wird jetzt auch in der Zaraffa Webapp korrekt angezeigt, Allerdings habe ich immer noch die gleiche Fehlermeldung.
Fetchmail läuft auf dem gleichen Host.

Mar 6 10:53:30 ucs fetchmail[2702]: Query status=10 (SMTP) Mar 6 10:55:31 ucs fetchmail[2702]: 1 message for zmail@radek-ldt.de at pop.1und1.de (3806 octets). Mar 6 10:55:31 ucs fetchmail[2702]: reading message zmail@radek-ldt.de@pop.1und1.de:1 of 1 (3806 octets) (log message incomplete) Mar 6 10:55:31 ucs fetchmail[2702]: Connection errors for this poll:#012name 0: connection to localhost:smtp [::1/25] failed: Connection refused.#012name 1: connection to localhost:smtp [127.0.0.1/25] failed: Connection refused. Mar 6 10:55:31 ucs fetchmail[2702]: SMTP connect to localhost failed Mar 6 10:55:31 ucs fetchmail[2702]: SMTP transaction error while fetching from zmail@radek-ldt.de@pop.1und1.de and delivering to SMTP host localhost Mar 6 10:55:31 ucs fetchmail[2702]: Query status=10 (SMTP)

hier noch die fetchmailrc

set daemon 120 set syslog set postmaster "postmaster" set bouncemail set no spambounce set properties "" poll pop.1und1.de with proto POP3 auth password user 'zmail@radek-ldt.de' there with password 'xxxx' is 'zmail@radek-ldt.de' here nokeep ssl #UID='hr'

Grüße

Harald Radek


#4

Hallo Herr Radek,

Die falsche primäre Adresse war nur verantwortlich für das Senden von Mails, sollte also den Fehler “invalid sender domain ldt.home” behoben haben. Wenn Sie jetzt nur noch von Fetchmail-Fehlern schreiben, nehme ich mal an, das Senden geht jetzt?

So, nun zu dem anderen Problem. Hier geht es ums Empfangen. Fetchmail sieht, daß Mails bei 1und1 liegen, und wenn es die lokal zustellen will, stellt es fest, daß da niemand auf Port 25 hört, an den es die Mails zustellen kann:

Nun müssen wir nur noch finden, warum… Auf welchen Ports unser Postfix hört, muß in der Datei /etc/postfix/master.cf stehen, bei mir steht ziemlich am Anfang:

# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (50)
# ==========================================================================
25      inet  n       -       n       -       -       smtpd

Wenn das bei Ihnen nicht so aussieht, kann man die Datei erneuern lassen mit:

root@hostname # ucr commit /etc/postfix/master.cf

Danach sollte die entscheidende Zeile (die mit 25 anfängt) drin stehen, und nach einem

root@hostname # postfix restart

sollte dann Fetchmail auch Mails zustellen können. Wenn nicht, schicken Sie am besten gleich die Ausgabe von

root@hostname # netstat -ntlp | grep -Ei 'master|smtp'

viele Grüße
Frank Greif.


#5

Hallo Herr Greif,

es geht jetzt. Der Eintrag mit dem Port 25 hat gefehlt. In der Univention Configuration Registry war unter mail/smtpport kein Eintrag vorhanden. lt. Hilfe sollte dann der Port 25 Standard sein. Erst nachdem ich 25 eingetragen hatte, funktioniert es jetzt.

Vielen Dank !

Harald Radek