UCS 3.2-3 und Windows 8.1

german

#1

Hallo,

ich hab versucht einen Windows 8.1-Client in die Samba 3-D0main zu joinen, leider klappt das nicht. Und anscheinend reicht es dann doch nicht wie unter Windows 7 den SDB-Eintrag zu befolgen und die reg-Datei zu importieren. Dieser Hinweis half auch nicht weiter, ich konnte daraus noch nicht mal eine brauchbare reg-Datei erzeugen. Ein manuelles setzen des Wertes führte dazu, daß die Daomain-Join-Funktion ausgegraut war. Aufgefallen ist mir, daß die UCS-Systeme in der Ntzwerkumgebung nicht auftauschen, ein Zugriff funktioniert aber. In der smbd.log gibt es keine relevanten Einträge.

Grüße


#2

So, ich hab den join hingekriegt, indem ich samba/max/protocol auf SMB2 gesetzt hab (war vorher auf NT1). Den Release-Notes von UCS entnehme ich, daß ich das in einer Umgebung von WIndows 7/8-Clinets so lassen kann. Ist das so richtig?


#3

Der scheint ja nun die WIndows 7-Profile zu nehmen, was aus verschiedenen Gründen problematisch ist. Kann man Roaming-Profile für diesen Client deaktivieren oder alternativ Windows 8 dazu bringen einen anderen Profilpfad zu nehmen?


#4

Hallo,

das ist so okay. Bei UCS Neuinstallationen (ab UCS 3.2) setzten wir SMB2 auch als Standard. Beachten Sie aber bitte dass Sie samba/max/protocol auf allen Samba-Servern in Ihrer Umgebung identisch setzen müssen.

Bzgl. der identischen Profilnamen gibt es einen KB Artikel bei Microsoft der o.a. beschreibt wie Sie die “UseProfilePathExtensionVersion” erhöhen können:
support.microsoft.com/kb/2887239/en-us

Mit freundlichen Grüßen
Janis Meybohm


#5

Vielen Dank für den Hinweis. Der Link war zwar für Windows 8, nicht für Windows 8.1, aber es hat so besxtens funktioniert. Der Hotfix selber ist inzwischen zumindest für Windows 8.1 über Windows Update verfügbar. Ich mußte also nur die Updates installieren und den Registry-Eintrag setzen. Jetzt funktioniert alles so wie es mir vorgestellt habe (auch wenn ein Umstieg auf Samba 4 mal so langsam an der Zeit ist, da braucht man dann auch keine Roaming-Profiles mehr).