UCR Cron Job startet nicht automatisch

german
cron
policy

#1

hallo,

ich habe ein kleine Backupskript geschrieben, dass wenni ch es es manuell auf der Console starte tut was es soll.
Ich habe versucht diese Skript Mo - Fr um 20:00 Uhr ausführen zu lassen. Dazu habe ich in der UCR 3 Variablen angelegt:
cron/autostart yes
cron/backup1/command /home/skripte/bacup_skript
cron/backup1/mailto Email-adresse
cron/backup1/time * 20 * * 1-5

Leider startet das Skript nicht.
Unter /etc/cron.d/univention-ucr-cronjobs ist das skript eingetragen:

# Warning: This file is auto-generated and might be overwritten by
#          univention-config-registry.
#          Please edit the following file(s) instead:
# Warnung: Diese Datei wurde automatisch generiert und kann durch
#          univention-config-registry überschrieben werden.
#          Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):
#
#       /etc/univention/templates/files/etc/cron.d/univention-ucr-cronjobs
#

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11"


MAILTO=mj@gtm.eu
*20 * * 1-5 root /home/skripte/backup_skript

Aber gemäß /var/log/syslog passiert nichts.

Wo kann ich ansetzen?
Vielen Dank für Eure Hilfe
Matthias Janbeck


#2

Hallo,

also wenn beim copy&paste nichts schief gegangen ist, dann ist das hier afaik keine valide Cron-Notation:

*20 * * 1-5

Da fehlt imho ein Leerzeichen:

* 20 * * 1-5

Auch würde das Skript in der Notation jede Minute zwischen 20:00 Uhr und 20:59 Uhr laufen (vgl. https://crontab.guru/#20_*_1-5)

Ich vermute folgendes wäre passender:

0 20 * * 1-5

#3

Hallo Grandjean,

ja das kann es schon gewesen sein :slight_smile: Habe den WErt korrigiert und warte den morgigen Tag ab, ob der Jobe heute Abend läuft.

Vorerst mal herzlichen Dank
Matthias Janbeck


#4

Hallo,

Der Fehler ist beseitigt. Das Skript ist gestern um 20:00 erfolgreich gestartet.

Vielen Dank für die schnelle Unterstützung.
Matthias Janbeck