UCC nouveau module deaktivieren

german

#1

Hallo,

ich möchte auf meinen UCC Client den nvidia-331 Treiber anstatt des nouveau verwenden.
Auf Ubuntu funktioniert es Problemlos, nur nicht mit UCC.

Das Problem ist, dass beim nvidia Treiber der nouveau nicht geladen werden darf.

Habe in der “/etc/modprobe.d/blacklist.conf” folgenden Eintrag erstellt:

blacklist nouveau

Rebootet, lsmod zeigt mir aber, dass der Treiber trotzdem geladen wird.

nouveau 969577 1 mxm_wmi 12893 1 nouveau wmi 18673 2 mxm_wmi,nouveau i2c_algo_bit 13197 1 nouveau ttm 72698 1 nouveau drm_kms_helper 46907 1 nouveau drm 243792 3 ttm,drm_kms_helper,nouveau video 18903 1 nouveau

Habe mit apt-get purge auch schon den “nouveau” Treiber deinstalliert, wird aber trotzdem weiterhin geladen.

Wo liegt das Problem? Auf Ubuntu14.04 am gleichen Rechner brauche ich nur nvidia installieren, nouveau deinstallieren und es funktioniert alles bestens


#2

Kernel Parameter behebt fürs erste das Problem:

modprobe.blacklist=nouveau

Aber warum funktioniert das mit der Blacklust nicht, hätte gerne eine schönere Lösung.


#3

Hallo,

ich habe mir den aktuellen UCC auf einer HP-Workstation mit nVIDIA Quadro Pro Karte installiert und möchte ebenfalls den nVIDIA-Treiber nutzen.

Kannst Du mir kurz die Vorgehensweise schilder? Wo trägt man den Kernel-Parameter ein und wie geht die Installation dann vonstatten?

Viele Grüße
Sven


#4

Also ich hatte noch nie einen Konflikt mit nouveau. Es reichte immer aus den nvidia-Treiber zu installieren, also z.B.

apt-get install nvidia-375

Allerdings habe ich keine Quadro Pro-Karten verbaut.


#5

Ja, im Handbuch steht dass man in der ConfigReg die Module blacklisten kann, da stand der nouveau bereits drin. Habe dann unter KDE/Plasma -> zusätzliche Treiber den nVIDIA installiert. Der funktioniert auch (siehe nVIDIA-Settings) aber beim boote erhalte ich seither unschöne Meldungen …


#6

Ja die erhalte ich leider auch. Der Plymouth-Screen von UCC 3 hat leider Probleme mit nicht-KMS-Treibern (also z.B. auch mit VESA). Das liegt nicht an nouveau. Im Gegenteil: nouveau unterstützt ja KMS.