Ubuntu Server 18.10 Domain Join Fails

Walked through enabling Univention PPA on an Ubuntu 18.10 headless server install.

After a reboot, I ran: sudo /usr/sbin/univention-domain-join-cli --skip-login-manager

After entering the credentials, the script fails to complete and issues an error. The following snippet is from the log file:

2019-03-02 12:22:36,298 userinfo CRITICAL An error occurred. Please check /var/log/univention/domain-join-cli.log for more information.
2019-03-02 12:22:36,302 debugging CRITICAL [Errno 2] No such file or directory
Traceback (most recent call last):
  File "/usr/sbin/univention-domain-join-cli", line 194, in <module>
    distribution_joiner.create_backup_of_config_files()
  File "/usr/lib/python2.7/dist-packages/univention_domain_join/distributions/ubuntu.py", line 78, in create_backup_of_config_files
    DnsConfigurator(self.nameservers, self.domain).backup(backup_dir)
  File "/usr/lib/python2.7/dist-packages/univention_domain_join/join_steps/dns_configurator.py", line 65, in __init__
    if DnsConfiguratorNetworkManager().works_on_this_system():
  File "/usr/lib/python2.7/dist-packages/univention_domain_join/join_steps/dns_configurator.py", line 144, in works_on_this_system
    stdout=subprocess.PIPE, stderr=subprocess.PIPE
  File "/usr/lib/python2.7/subprocess.py", line 394, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1047, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
type or paste code here

It appears the script is failing to create the required backup files necessary to proceed. Is this a bug that should be reported or is there an issue with the file system that should be addressed?

Is this an isolated issue? A ‘one off’? Too few actually use Ubuntu?

Very curious if there’s any support for binding Ubuntu to the Directory. Anyone?

Univention Domain Join supports the following Linux distributions:

Ubuntu 18.04 LTS („Bionic Beaver“)
Linux Mint („Tara“)
Ubuntu 17.10 („Artful Aardvark“)
Ubuntu 16.04 LTS („Xenial Xerus“)
Ubuntu 14.04 LTS („Trusty Tahr“)

Did you try

univention-domain-join-cli --master-ip x.x.x.x --skip-login-manager

I have a test system with 18.04 LTS and it works perfect for me

Greetings Ben

Perhaps Ubuntu 18.10 introduced changes to the file system layout or permissions schema that breaks the script.

univention-domain-join-cli --master-ip x.x.x.x --skip-login-manager continues to yield the same error noted in the original post.

Appreciate you at least responding!

You system is missing is the CLI tool “nmcli”. You could install it via “sudo apt-get install network-manager”.

I created a bugzilla entry for this:
https://forge.univention.org/bugzilla/show_bug.cgi?id=49103

1 Like

Indeed it was missing and the installation of the Network Manager group was the solution.

Thank you!

I am getting the same error. I installed Network Manager (begrudgingly), and get a new error. Seems the script is trying to configure DNS for me, when netplan.io is already integrated.
Does this script support netplan.io? It seems like it does not. The bug report above is detailing the main problem with univention-domain-join-cli and univention-domain-join, they are trying to do too much.
Mainly it seems that you MUST have network-manager installed, and you MUST not have any other networking configured. This is not detailed in any of the documentation.
I would strongly recommend adding a flag that ignores setting up DNS. Most admins know to do this before integrating a client into AD.
Let me configure DNS, and dont touch my networking configurations. Let the script take care of configuring Kerberos, and other configurations.