Ubuntu 20.04 cifs mount of UCS 5 share not possible

Hello all,

I used to have a old ubuntu 16.04 server machine, that had a cifs mount of a UCS share that worked for years without any problems.
After update to UCS 5 this mount was not working anymore. Mounting was no longer possible. I thought this is due to the old Ubuntu version, maybe some SMB version issues, so I set up a new machine with Ubuntu 20.04 server. The old machine was never part of the UCS domain. The new one is not either.

Everytime I try to mount the share via mount -a I get

mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

dmesg says

[ 4912.185746] CIFS: Attempting to mount //fips-server2/share
[ 4912.245052] CIFS VFS: \\fips-server2 Send error in SessSetup = -5
[ 4912.245093] CIFS VFS: cifs_mount failed w/return code = -2

I try to mount using fstab. fstab entry is following

//fips-server2/share /media/share cifs credentials=/home/superuser/.smbcredentials,vers=3.0,iocharset=utf8,uid=0,gid=1000 0 0

Until now I have not found somethin that solves this problem. Does the ubuntu machine has to ba part of the domain recently?
I also have some raspberry pis here that are not part of the domain, but can mount shares of the same server without problems. What am I doing wrong?
I would be glad about any help.

Should work: at least I was able to mount a share from my UCS 5.0-1 Samba4 system on my UCS 4.4-8 test host.

Do diagnose such kind of problems first try to get the underlying tool mount.cifs to work by invoking it directly, e.g.

mount.cifs \
  //fips-server2/share /media/share \
  -o credentials=/home/superuser/.smbcredentials,vers=3.0,iocharset=utf8,uid=0,gid=1000 \
  --verbose

Hopefully that will show you more information due to the use of --verbose.
For testing even replace your credentials=… with user=…phahn,pass=… to rule out any miss-configuration there.

Thanks for your reply. Now it works again.
I don’t know why it stopped working after the update of UCS. I always used the same credentials than I did all the time. But I had to reset the password of the UCS user I used to mount the share. After that it worked again. Strange, but thanks.