Ubuntu 19.04 Domain Join


#1

Hi,

at the moment, if I use this command on 19.04:

add-apt-repository ppa:univention-dev/ppa

I get this answer:

E: The repository 'http://ppa.launchpad.net/univention-dev/ppa/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

If installed on 18.10 and then upgraded, the client is still in the domain, but it takes much longer to do so.

I need this quite urgently for a customer who wants to join more than 200 clients.

Can this be fixed on short notice?

Cheers,
Roland.


#2

Hi Roland,
at the moment there is no repository for 19.04 (Disco Dingo). Latest repo is for 18.10 (Cosmic Cuttlefish).
https://launchpad.net/~univention-dev/+archive/ubuntu/ppa
ppa1


#3

Hi,
yes, I know that this is the problem.

I just tried to install it manually and I guess the problem is that the package auth-client-config is not available in Disco Dingo.
Don’t know how to work around that, though.

EDIT: I just installed the bionic version of auth-client-config and it works now.
It’s a bit tricky though.

Here the necessary steps:
Copy the python join script from another machine to the 19.04 client:
/usr/share/univention_domain_join/cli.py
Also create the symbol link:
/usr/sbin/univention-domain-join-cli -> /usr/share/univention_domain_join/cli.py

Install the packages:
apt install sssd libnss-sss libpam-sss libsss-sudo heimdal-clients ntpdate sshpass python python-pip

Zip the folder:
/usr/lib/python2.7/dist-packages/univention_domain_join
on a working machine and copy it over to 19.04. Unzip it.

Install the other necessary python packages:
pip install IPy
pip install dnspython
pip install netifaces

And finally download and install the auth-client-config from Bionic Beaver:
wget http://de.archive.ubuntu.com/ubuntu/pool/universe/a/auth-client-config/auth-client-config_0.9ubuntu1_all.deb
dpkg -i auth-client-config_0.9ubuntu1_all.deb

Then the join works.

I need to script all that stuff, so does anyone know a simpler solution?

Cheers,
Roland.


#4

Hi,

I’d recommend to create a feature request like https://forge.univention.org/bugzilla/show_bug.cgi?id=48114 but for 19.04.
In case you customer has a valid subscription for UCS domain service you should also contact Univention Sales and notify them.
BTW: Is there any technical reason for this customer to use one of the quickly changing releases instead of LTS?

cheers,
Dirk


#5

Hi,
thanks.
Seems like the auth-client-config problem was already there for 18.10, so Univention added it to the PPA.
Therefore I guess it’s no problem to add 19.04

My customer has a valid subscription, of course :slight_smile:

He had big problems with printers, which are solved in 19.04
There were other issues, too - but I don’t know the details.

Here’s the “Bug” Report:
https://forge.univention.org/bugzilla/show_bug.cgi?id=49789

Cheers,
Roland.