Übernahme NT Computerkonten --> falsches Passwd. Datum?

german

#1

Wir haben Computerkonten usw. von einem NT4 PDC nach UCS 1.3 migriert.
Ich möchte die Konten jetzt nach dem Datum der letzten Passwortänderung (sambaPwdLastSet) filtern, um alte Konten zu löschen.
Das Datum ist als Unix time stamp gespeichert und muss umgerechnet werden.
Ldapsearch gibt mir jetzt aber nur 9 stellige Datumsstrings zurück, was als Ergebnis ein Jahr in den 70ern ausgibt.
Kann es sein, das bei der Migration hier eine Stelle des Strings unterschlagen wurde?

ldapsearch -LLL -x -h localhost -D uid=Administrator,cn=users,dc=foo -w geheim-b cn=computers,dc=foo |grep sambaPwdLastSet


sambaPwdLastSet: 105755390
sambaPwdLastSet: 113800059
sambaPwdLastSet: 996143469

date -d '1970-01-01 105755390 sec' +"%Y-%m-%d %T %z"
1973-05-09 00:29:50 +0100

date -d '1970-01-01 [b]1[/b]105755390 sec' +"%Y-%m-%d %T %z" 
2005-01-15 02:16:30 +0100

Gruss,
Frank Müller


#2

Wir konnten das Problem lokalisieren und lösen.

Sie finden hier aktualisierte Samba für UCS 1.3-0.
http://bitz150.bitz.briteline.de/download/packages/samba/

Nach einer erneuten Übernahme sollten die Zeiten korrekt gesetzt sein.


#3

Vielen Dank.
Eine Frage noch:
Muss die Datenbank vor einem neuen Takeover geleert werden? Oder reicht ein apt-get upgrade und univention-pdc-takeover?


#4

Hallo,

die neuen Pakete sollten mit univention-repository-addpackagedem lokalen Repository hinzugefügt und mit apt-get update && apt-get upgradeinstalliert werden. Danach kann univention-pdc-takeover direkt wieder aufgerufen werden, manuelles bereinigen einer Datenbank ist nicht nötig.

Mit freundlichen Grüßen,

Wolf Wiegand


#5

Nach einigen Schwierigkeiten hat es geklappt. Danke.

Zuerst trat beim takeover diese Fehlermeldung auf:

26.01.06 11:09:50  DEBUG_INIT
26.01.06 11:09:51  MAIN        ( ERROR   ) : Found more than on Samba Domain Object.
26.01.06 11:09:51  MAIN        ( ERROR   ) :    -> RITTAL1DOM1 (sambaDomainName=RITTAL1DOM1,cn=samba,dc=flg)
26.01.06 11:09:51  MAIN        ( ERROR   ) :    -> UCS (sambaDomainName=UCS,dc=flg)

Richtig wäre “sambaDomainName=RITTAL1DOM1,dc=flg”

Wir haben dann im UCS Admin das Objekt “UCS (Settings: Sambadomain)” nach RITTAL1DOM1 umbenannt.
Danach brach der takeover Prozess mit dieser Meldung ab:

26.01.06 11:15:39  DEBUG_INIT
26.01.06 11:15:39  MAIN        ( ERROR   ) : Found more than on Samba Domain Object.
26.01.06 11:15:39  MAIN        ( ERROR   ) :    -> RITTAL1DOM1 (sambaDomainName=RITTAL1DOM1,cn=samba,dc=flg)
26.01.06 11:15:39  MAIN        ( ERROR   ) :    -> RITTAL1DOM1 (sambaDomainName=RITTAL1DOM1,dc=flg)

Erst nachdem wir das Objekt im UCS Admin komplett gelöscht haben, lief der takeover durch.

Im Admin wird jetzt aber wieder eine “UCS” Objekt angezeit, nicht RITTAL1DOM1.
Und eine LDAP Abfrage gibt auch zwei Domänennamen zurück:

 ldapsearch -LLL -x -h localhost -b dc=flg | grep sambaDomainName
dn: sambaDomainName=RITTAL1DOM1,cn=samba,dc=flg
sambaDomainName: RITTAL1DOM1
dn: sambaDomainName=UCS,dc=flg
sambaDomainName: UCS

Ist das so korrekt? Brauchen Sie noch mehr Informationen?


#6

Das LDAP Objekt sambaDomainName=UCS,dc=flg kann gelöscht werden und auf allen anderen UCS Systemen muss der neue Domänenname gesetzt werden

univention-baseconfig set windows/domain=RITTAL1DOM1

#7

Ab UCS1.3-0 ist es möglich systemspezifische Einstellungen mit Univention Setup zu verändern.

Für das Ändern der Windows Domäne verwenden Sie das Programm univention-setup-basis.

Univention Setup wird im folgenden Artikel genauer beschrieben:
http://www.univention.de/forum/viewtopic.php?t=100