To less disk space for update


#1

Hi,
during update I got the follwoing error message:

Checking for space on /var/cache/apt/archives:
failed ERROR: Not enough space in /var/cache/apt/archives, need at least 4000 MB. This may interrupt the update and result in an inconsistent system! If necessary you can skip this check by setting the value of the config registry variable update43/checkfilesystems to "no". But be aware that this is not recommended!

The disk size on the system looks like this. The system runs on vmware and has a disk size of 100GB. I’m wondering about only the half disk size usable for / und a big size for docker/overlay. How can I solve this problem? Do I have to expand the filesystem or can I clean up the docker/overlay area?

root@ucs-nc01:~# df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
udev             10M       0   10M    0% /dev
tmpfs           3,2G     13M  3,2G    1% /run
/dev/dm-0        45G     11G   33G   25% /
tmpfs           7,9G    4,0K  7,9G    1% /dev/shm
tmpfs           5,0M       0  5,0M    0% /run/lock
tmpfs           7,9G       0  7,9G    0% /sys/fs/cgroup
/dev/sdb1        73G    9,2G   60G   14% /var/lib/univention-appcenter
/dev/sda1       472M    225M  224M   51% /boot
overlay          45G     11G   33G   25% /var/lib/docker/overlay/6d5dba4a11009198f0adfea72b8ab340714282e0852709de98b9dda345af5ebe/merged
shm              64M       0   64M    0% /var/lib/docker/containers/72a344c1d5ce7050ad6370247ff9516230894d53460e0a634afe78b010cbbc12/shm
root@ucs-nc01:~#

#2

Moin,

the overlay device mounted on /var/lib/docker/overlay/... is actually /dev/dm-0, i.e., the root filesystem /. From the partitioning I’d guess, the system was created with a 50G disk and the missing 4.5G are swap.

What is the output of the following commands?

# pvs
# lvs
# fdisk -l /dev/sda


#3

Hi bytemine,

here comes the output:

root@ucs-nc01:~# pvs
  PV         VG     Fmt  Attr PSize  PFree
  /dev/sda5  vg_ucs lvm2 a--  49,52g    0
root@ucs-nc01:~# lvs
  LV     VG     Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  root   vg_ucs -wi-ao---- 46,27g
  swap_1 vg_ucs -wi-ao----  3,25g
root@ucs-nc01:~# fdisk -l /dev/sda

Disk /dev/sda: 50 GiB, 53687091200 bytes, 104857600 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xef7f374d

Device     Boot   Start       End   Sectors  Size Id Type
/dev/sda1  *       2048    999423    997376  487M 83 Linux
/dev/sda2       1001470 104855551 103854082 49,5G  5 Extended
/dev/sda5       1001472 104855551 103854080 49,5G 8e Linux LVM

root@ucs-nc01:~#

#4

Moin,

this line shows, that the disk (at least as seen from the virtual machine) still has a size of 50G, not 100G.


#5

Hi,
here is the screenshot of the machin setting in vmware…
grafik
How can I solve the problem? Bigger hard Disk in vmware and expand the volume?


#6

I guess there is some miscalculation in place.
Update checker talks about 4000MB. On your / you have 33GB free. So it should fit.
Just to make sure there is no other issue: please rescan your devices with “rescan-scsi.bus.sh” or either reboot your virtual machine to have the full100GB in your virtual machine.

Once done, check again with “df -h” AND “df -i”


#7

Sorry for my delay. Meanwhile I’m in my easter holidays:grinning:.
This evening I solved my problem by the assistance of the following support article: Resize LVM on UCS
After entering the command lsblk I saw that there is indeed a 100G disk and I had to extend the lvm group.

root@owncloud-01:/usr/bin# lsblk
NAME              MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
fd0                 2:0    1    4K  0 disk
sda                 8:0    0  **100G**  0 disk
├─sda2              8:2    0    1K  0 part
├─sda5              8:5    0 49,5G  0 part
│ ├─vg_ucs-swap_1 254:1    0    2G  0 lvm  [SWAP]
│ └─vg_ucs-root   254:0    0 47,5G  0 lvm  /
└─sda1              8:1    0  487M  0 part /boot
root@owncloud-01:

Thanks for your support.