TLS Problem

mail
german

#1

Hallo zusammen,
habe seit einiger Zeit univention mit open exchange im einsatz. Da mein mail relay auf TLS umgestellt wurde muss auch ihc umstellen. Allerdings bekomme ich immer folgende Fehlermeldung:
TLS server engine: No CA file specified. Client side certs may not work

Und mail koennen nicht versendet werden. Zertifikate sind vorhanden und auch in Ordnung.
Kann mir jemand weiter helfen?
Danke schon mal


#2

Hallo,

die Meldung TLS server engine: No CA file specified. Client side certs may not work sollte keine Auswirkungen auf den Mailversand haben. Um weitere Hinweise geben zu können wäre es hilfreich wenn Sie angeben könnten welche Änderungen am Sie am System vorgenommen haben. Wie war die Konfiguration vor der Umstellung auf TLS? Wie ist die Konfiguration jetzt? Welche weiteren Meldungen gibt es unter /var/log/mail.log beim versenden einer Mail?

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo,
vielen Dank für die schnelle Antwort. Es wurden lediglich Änderungen am relay-Server vorgenommen. Er wurde so angepasst, dass nur noch TLS Verbindungen angenommen werden. Vor der Änderung wurden alle Verbindungen aktzepiert.
mail.log gibt folgendes aus:
Dec 8 15:25:24 mail-server postfix/smtp[26197]: 14B71A0002: to=xxx@web.de, relay=relay.xx.de[141.xx.xx.xx]:25, delay=0.08, delays=0.06/0.01/0.02/0, dsn=5.7.0, status=bounced (host relay.xx.de[141.xx.xx.xx] said: 530 5.7.0 Must issue a STARTTLS command first (in reply to MAIL FROM command))

vielen Dank

Markus


#4

Hallo,

derzeit ist es nicht per UCR möglich TLS für ausgehende Verbindungen zu aktivieren ([bug]15786[/bug]).
Als Workaround können Sie die Option “smtp_tls_security_level = may” manuell in die Datei /etc/postfix/main.cf (bzw. in das entsprechende Template) aufnehmen und Postfix neu starten.

Mit freundlichen Grüßen
Janis Meybohm


#5

hey Meybohm,
vielen Dank. Jetzt funktionierts wieder. :slight_smile:

gruß Markus