Time problem even with multiple trying there is always a time gap


#1

hello im still new with Univention im trying to work with it in vmware workstation im still learning . i noticed alot of times the server makes big time different like the first time it was 2.5 hours different i tried everything but nothing wanna work i reinstalled it and i got 8 mins different and after that another new installation and still 10 mins 9 mins i have installed more than 8 times and still the same problem. i even downloaded the vmware version from univention itself and still have the same problem . i tried to force time change but when i reboot the system it goes back to the same time different . i also add the time servers and still nothing works there is all the time a from 2.5 hours to 9 mins different .

anyone can help me with this problem?


#2

Hi,
do you use the “supend/ pause” feature of VMware?
Do you have the open-vm-tools installed?
Is ntpd running properly?
Is your workstation capable of hosting a UCS virtual machine (by memory, cpu, hdd)?

I run several instances on VMware (but ESXi) an do not have any issues with time-sync.

/KNEBB


#3

hi
i havent use the suspend feature in vmware i also checked the ntpd and i add the time servers manually i made a machine with 4g rams and20 g hdd i gave it more than recommended also i used the vmware virsion from univention itself and still haveing the time problem and after few installations one of them is now less than 5 mins time different i still cant make any client join the domain


#4

Again,

sure ntpd is configured properly? What does
ntpq -p and
apt search open-vm-tools
say?

And you did not answer my question if your Windows-Workstation is capable of hosting the UCS virtual machine. How many virtual machines do you have powered on? How much RAM is assigned and how much RAM does your VMware machine have? Ist the time of the hosting machine set properly?

/KNEBB


#5

im in Belguim i configured the time zone as brussels and now the time is 15 seconds different and i also add the time servers this is what it shows


#6

According to your output there is no time-server configured. The local clock in a virtualized machine usually is not reliable.
Either install open-vm-tools or configure external time servers for your domain controller (prefferred).


#7

can u help me do it because i have been only useing linux for 1 month now im still learning and its really hard for me


#8

Well, there is no need for Linux knowledge:


Set three timeservers and your ntpd should sync with the external source. But this might taks several minutes, be patient!

Otherwise on the command line:
apt install open-vm-tools

Either way should work.


#9

i tried the time server before i went online and i got the ip address from of the time servers in Brussels but it still didn’t work but im gonna try it again also im gonna try the vm tools and let u know


#10

On UCS, please always install packages via the UMC or use univention-install <packagename>


#11

i installed the vm tools and it worked very good thanks alot bro :slight_smile: your the best