Thunderbird Timeout


#1

Hi,
I have UCS 4.2 acting as domain master, dhcp, dns. I have 20 UCC clients and 5 Windows. From a few days to now, a thunderbird timeout problem occurs only in the UCC, on Windows machines, thunderbird works fine. I’ve done a check in all configurations, I could not detect anything abnormal. Strange that in Windows works ok. The problem occurs only in equipment with UCC. If you insist, and open and close thunderbird several times, sometimes it works. Most of the time, the problem of timeout, both to receive when to send. I’ve tested another email client on UCC, Evolution, and there’s also the same problem. By testing with ping and traceroute, the response times of the mail server are normal. He repeated that Windows clients work normally, the problem only occurs in UCC clients.
Do you think that any configuration in UCS could be causing this problem in the UCC?

Best Regards,
Michael


#2

Hey,

do your UCC machines have IPv6 addresses? Do your servers? Are your DNS entries resolved to both IPv4 and IPv6 addresses?

It sounds a bit like your Thunderbird is running on a dual-stacked setup (machine has both IPv4 and IPv6 addresses), resolves names like imap.yourdomain to both IPv6 & IPv4, tries to connect via IPv6 but those aren’t answered.

Kind regards,
mosu


#3

Hey,

It looks exactly like this, however, I deactivated ipv6 and in thunderbird, I used ipv4 direct in the pop and smtp settings. The result is the same. With this I discarded being ipv6 and dns. The curious thing is that this only happens in the UCC, in Windows everything normal.

Any idea?

Best Regards,
Michael Voigt


#4

Hey,

alright, excluding DNS & IPv6/IPv4 issues by using IP addresses directly is definitely a good step. At that point I’d now capture the network traffic produced when Thunderbird tries to access an account and analyze that traffic with Wireshark.

m.


#5

Hey,
I think the problem may be related to IPV6. After restarting UCS Server, all UCC clients have improved. Could you pass me the configuration to disable IPV6 on UCS and on all UCC clients? Can I disable IPV6 on UCC clients via policy?

Best regards,
Michael Voigt


#6

Hey,

I don’t know how to disable IPv6 because I haven’t done that in a looooooooong time. Quite the opposite; I run IPv6 wherever possible.

m.


#7

Hey,
I discovered that the hole was lower. Analyzing the traffic, it was possible to understand that the UCC clients were lost when in simultaneous use of several equipments. The failure is in the TCP-IP protocol timestamps. To resolve it was necessary to add the following parameter in the file /etc/sysctl.conf
net.ipv4.tcp_timestamps = 0

Best regards,

Michael Voigt