The import of the license failed. Check the integrity of the original file given to you

license

#1

have applied for 3 licences and each time when i import the license i see this error message.

not sure what to do next as i can’t see any issue with the file when opened with a text editor

rupert


#2

needed to restart the server???

now imported ok…

might be good to include this in instructions??

rup


#3

I’ve never seen such a message, and I certainly have never had to restart the server for a license import to take effect. Quite curious.

Assuming you’ve received the license file via email: how did you transfer the license to the server? I highly recommend you do not try to do anything via copy & paste. Instead save the license file in your mail client to a text file, then transfer the license file via scp (on a Windows client you can use WinSCP) to the server, log in, run univention-license-import name-of-file-you-have-just-transferred.txt


#4

I have an official license and when I import the license I see this 2 error massage

univention-license-import   name of the file I have transferred.txt
E:license file contanign mor than on DN


Notification 
The import of the license failed. Check the integrity of the original file given to you. If this error persists, please contact Univention or your Univention partner.
Server error message:
The LDAP base of the license does not match the LDAP base of the UCS domain (dc=campus,dc=ba,dc=edu,dc=af).

#5

Hey,

the DN in the license file must be the same that your server is using as its base DN. You can verify that by comparing the output of grep '^dn:' your-license-file.license with ucr get ldap/base

If they differ, then the license won’t work. I assume that it’s just due to a typo or some other honest mistake. In that case do what the error message says: contact whoever you purchased the license from, explain the situation and and ask them to change the license to the correct DN.

Kind regards,
mosu


#6

Hi,

I got the same error, I thought i’d quickly reboot the server while I installed filezilla to SCP and after a reboot the import completed without a problem!