Switch from ESXi to Hyper-V: no login possible, no network

Good afternoon,

I’ve been running UCS on an ESXi 6.0 for quite some time now and now want to switch to Hyper-V for other reasons.

I tried to convert the VM using the Microsoft and Starwind converters but get a lot of errors during booting (e.g. failed to bind domain name server with samba4 backend).
I have set up a network switch which worked fine for another Windows VM I converted as well as an Ubuntu one, so the conversion process and network do work in principle.

When bootup is finished I’m presented with the login screen but entering valid credentials always brings me back to the login screen.

Also the VM is not reachable via ping.

Does anyone have a tip for me?

Many thanks!

Stay healthy


Hi toko42,

some time ago i switched a UCS-Server from ESXi 5.5 to Hyper-V.

This path worked without problems for me:

  • Create a Backup with Clonezilla of the virtual ESXi-UCS-VM
  • Restore the backup in the Virtual-Hyper-V VM


O. Bertgen


Thank you very much for the tip.

But as I don’t use Clonezilla, yet (only Veeam Agent) how do I do this?
Boot the VM from the Clonezilla boot medium and backup to whichever share?

Can Clonezilla connect to a Windows share? I haven’t been successful with Veeam Agent regarding this and don’t have another Linux machine with enough space to fit the clone.

I’ll just add another disk to the VM and format it with ext4.
Will probably have to wait until the weekend.

Thanks again

T. Kowalski

I’ve now tried Clonezilla but with the same results (except that I got them way faster, Clonezilla works faster than the converters).

So I’m stuck at a login prompt and thus can’t change the network interface which should be the only problem to be solved.

What would be possible solutions?
Deleting the global network settings before powering down?
What about adding a new UCS server as secondary DC, promoting it afterwards and removing the orignals server? Much like doing when taking over a Windows domain.

I appreciate any help because I’m really stuck now.

Many thanks.

T. Kowalski


which “login prompt” do you mean?

Really on the console? Or the Web-Interface?

In the first case, which credentials do you use? You should use “root” as username, not Administrator. (might be the LDAP-server is down, therefore).


Hello Christian,

that did the trick!
I always used Administrator, even on the console.

Thank you very much!

I’ll deal with the network configuration later.

So I’m logged in now thanks to Christian’s advice but haven’t figured out how to change the IP address.

According to this article I can do it using the given commands:

But before I had a network interface ens192 now it’s docker0 and changing the gateway results in an error message referring to ens192.
Also, i can’t see the change of IP address for docker0 which didn’t give an error message.

Step by step :slight_smile:

Thank you very much for your support!

Best regards


Ignore the docker0 for the moment. As the name states it is just for Docker, not for the real network.

I guess your naming schema has changed because of different network interface cards (NIC) in HyperV compared to ESXi.

So it would not be ens192 but a different name. Try to figure it out by checking boot messages or other stuff. What does ip a show display?


Ah, that was too easy, I have only tried ifconfig.

ip a show returns an eth0 adapter indeed but when I try to change address and gateway, I have the same results as above.

As I can’t use the regular debian tools to set the adapter on the cli, I’m at a loss, again :pensive:

Again: Thank you very much for your support.


use the command ucr to configure.
So for ens192 it looks like this:

interfaces/ens192/ipv6/acceptRA: false
interfaces/ens192/netmask: 24
interfaces/ens192/start: true
interfaces/ens192/type: static
interfaces/primary: ens192

You will need to set your ucr variables according to your needs, so you might want to set (as example):
ucr set interfaces/eth0/address=
And do so for all other values. Use the above lines (or the output of ucr search --brief interfaces/ens192) as reference.

Unset the old variables after this:
ucr unset interfaces/ens192/address


That worked like a charm!

Thank you very much and have a nice weekend!

Best regards