Starting Univention Directory Policy failed

german

#1

Hallo
Nach dem letzten Update will der Server nicht mehr wirklich :slight_smile:

[quote]root@ucs-8183:~# service univention-directory-policy start
[FAIL] Starting Univention Directory Policy: failed!
root@ucs-8183:~#
[/quote]

In /var/log/univention/ldap.log steht folgendes[quote]run-parts: /usr/lib/univention-directory-policy/univention-policy-set-repository-server exited with return code 1
could not open policy for cn=ucs-8183,cn=dc,cn=computers,dc=behrmann,dc=intranet
[/quote]

Wer weiß Rat?
Gruß Torsten


#2

Nachtrag: Ein [quote]ldapsearch -x -ZZZ -s base -h ucs-8183.behrmann.intranet
[/quote] ergibt:

[quote]root@ucs-8183:~# # extended LDIF

LDAPv3

base <dc=behrmann,dc=intranet> (default) with scope baseObject

filter: (objectclass=*)

requesting: ALL

search result

search: 3
result: 1 Operations error
text: 00002020: Operation unavailable without authentication

numResponses: 1

[/quote]

Zur Info: Hab’ am Freitag noch das root-Passwort neu gesetzt
Gruß Torsten


#3

Du mußt dich am LDAP schon authenfizieren. Was ist die Ausgabe von

univention-ldapsearch cn=ucs-8183

#4

Hallo
Die Antwort kam leider zu spät…
Hab’ den Server neu aufgesetzt

Bzw. Wollte den Server neu aufsetzen
Leider läuft die Installation nicht durch…

Am Ende kann ich nur noch rebooten, anmelden und die
Schaltjahr-Befehle eingeben.
Wenn ich mich dann an der UMC anmelde, geht die Installation weiter…

Am Ende kann ich mich trotzdem nicht an der UMC anmelden…
Der “univention-management-console-web-server” scheint nicht zu laufen

Im Log steht dann auch “day is out of range for month”
Wer kann einen Verzweifelten helfen?
Gruß Torsten


#5

Was bedeutet am Ende? Nachdem die Installation durchgelaufen ist und das System neu gestartet wurde?


#6

Hallo

Erstmal vielen Dank für die Hilfe :wink:

Nach Netzwerk, Partitionen, Grundsystem, zusätzl. Software und grub
beginnt der “Univention-System-Setup”. Und dann hängt die Installation
in einer Schleife (Fehler unter anderem):

  • PAM unable to dlopen(pam_ldap.so) /lib/security/pam_ldap.so
  • D-BusLibrary appears to be incorrect setup
    Failed to open /etc/machine-id

Hat der Fehler mit dem Schaltjahr-Problem zu tun?
Gruß Torsten


#7

Nachtrag:
Auf dem Installation-Screen (F5) erscheint ein Fenster:
“Bis jetzt schlug die Authentifizierung fehl. Nichtsdestotrotz wird weiterhin probiert”

Gruß Torsten


#8

Hier noch eine Anleitung in Englisch, wie ich mein Testsystem erfolgreich installieren konnte: forum.univention.de/viewtopic.p … 943#p19370


#9

[quote=“oberp”]Nachtrag:
Auf dem Installation-Screen (F5) erscheint ein Fenster:
“Bis jetzt schlug die Authentifizierung fehl. Nichtsdestotrotz wird weiterhin probiert”

Gruß Torsten[/quote]

Ja, das liegt leider an dem Schaltjahr Problem. Hilft die Anleitung aus dem referenzierten Beitrag?


#10

Konnte alle cmds ohne Probleme ausführen, nach Alt+F5 und Refresh
bleibt der Bildschirm blank und unter F4 laufen die gleichen Fehler auf…
Gruß Torsten

PS.: Kann ich nicht nach dem reset die UMC nachinstallieren?


#11

Nachtrag:
Statt “sed -i 's|expires.year…” muss es bei mir “sed -i 's|expiration.year…” heißen

Dann F5 plus Refresh und die Installation geht weiter…
Wird 'ne lange Nacht
Gruß Torsten


#12

Guten morgen
Ich bin jetzt ein ganzes Stück weiter, konnte einiges retten… :slight_smile:

Der Mailserver will noch nicht so richtig (/var/log/mail.info):

[quote]Mar 1 06:36:48 ucs-8183 postfix/qmgr[29065]: EC8702FC51F: to=rudi.schoenawa@behrmannbremen.com, relay=none, delay=1807, delays=1807/0.56/0/0, dsn=4.3.0, status=deferred (mail transport unavailable)
[/quote]
…und…

[quote]Mar 1 06:41:47 ucs-8183 postfix/smtp[29228]: 5BF842FCC4C: to=rudi.schoenawa@behrmannbremen.com, relay=none, delay=692, delays=692/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
[/quote]

Wer weiß Rat?
Gruß Torsten
ucr_dump_mail.txt (3.52 KB)


#13

Moin,

Port 10024 ist normalerweise der Anti-Spam- und Anti-Viren-Scanner Amavis. Schauen Sie mal, ob der läuft. Falls nicht: starten. Beim Start schreib Amavis jede Menge Meldungen ins mail.log, sodass Sie bei Problemen mit dem Start von Amavis hier nachschauen können.

Gruß,
mosu