SQL-Server geblockt?

german

#1

Hallo an alle

Ich versuche verzweifelt, im Netzwerk einen MS-SQL-Server für die Windows-Client zu installieren.
Hab’ schon hier im Forum gesucht/gegoogelt. Fündig geworden bin ich aber nicht so richtig…

Hab’ schon folgendes versucht:

  • ucr set security/packetfilter/tcp/1433/all=ACCEPT
  • ucr set security/packetfilter/tcp/1434/all=ACCEPT
  • service univention-firewall restart

“iptables -L | grep ms” gibt dann folgendes aus:[quote]
ACCEPT tcp – anywhere anywhere tcp dpt:ms-sql-m
ACCEPT tcp – anywhere anywhere tcp dpt:ms-sql-s[/quote]

und “nmap 192.168.10.5 -p 1433-1434” (192.168.10.5 ist der Server mit dem SQL-Server)[quote]
Starting Nmap 6.00 ( nmap.org ) at 2015-08-29 10:54 CEST
Nmap scan report for faxi.xxxxxxxxx.intranet (192.168.10.5)
Host is up (0.00029s latency).
PORT STATE SERVICE
1433/tcp filtered ms-sql-s
1434/tcp filtered ms-sql-m
MAC Address: xx:xx:xx:xx:xx:xxHewlett-Packard Company)

Nmap done: 1 IP address (1 host up) scanned in 1.51 seconds[/quote]

und “nmap -p1433-1434 192.168.10.1” folgendes[quote]
Starting Nmap 6.00 ( nmap.org ) at 2015-08-29 10:45 CEST
Nmap scan report for ucs-8183.xxxxx.intranet (192.168.10.1)
Host is up (0.000057s latency).
PORT STATE SERVICE
1433/tcp closed ms-sql-s
1434/tcp closed ms-sql-m

Nmap done: 1 IP address (1 host up) scanned in 0.18 seconds[/quote]

Auch versucht hab’ ich “ucr set security/packetfilter/disabled=yes”
plus “service univention-firewall restart”

Mhhh?? Port 1433/1434 auf dem UCS sind immer closed. Wie bekomme ich die Ports geöffnet?
Oder bin ich ganz verkehrt?

Gruß Torsten


#2

Hallo,

leider kann ich dein Vorgehen nicht so ganz nachvollziehen. Ich nehme doch stark an, daß der MS-SQL-Server auf einem Windows-Server läuft und nicht auf einem UCS. Ergo muß die Firewallkonfiguration auf dem Windows-Server geändert werden und nicht die auf dem UCS sofern der nicht auch noch Router spielt.

Sofern ich hier jetzt falsch liege und ich dir nicht weiterhelfen konnte, wäre eine Skizze deiner Netzwerkkonfiguration hilfreich.

Grüße
SirTux


#3

Hallo SirTux
Erstmal danke fürs schnelle Antworten…
Asche auf mein Haupt!!!
Hab’ heute morgen den SQL-Server neu aufgesetzt und vergessen, die Firewall auf den Windowsrechner mit dem SQL-Server wieder auszuschalten :frowning:
Jetzt geht es jedenfalls, trotzdem danke
Gruß Torsten, und schönes WE

PS.: Hab’ noch ein UCS-Problem mit ausgehenden Emails (postfix, relayhost ???), check das aber Montag