Spamassassin blacklist und whitelist Einstellungen

german

#1

Hallo Zusammen,

ich nutze Zarafa, amavis und spamassassin.

Mein Problem ist, dass ich es nicht hinbekomme Spammassin eine Blacklist zu verpassen. Nachdem was ich gelesen habe, solle man

Blacklist_from user@domain

in die local.cf schreiben. Ich habe 2 local.cf und habe es bei beiden versucht einfach ganz am ende das oben genannte einzutragen, jedoch ohne Reaktion. Emails kommen nach wie vor durch.

/etc/spamassasin
/etc/mail/spamassin

Kann mir jemand sagen, an welcher Stelle ich den Eintrag richtig mache? Scheinbar sind beide oben genannten falsch.

Versionen der Pakete:
UCS 4.0-2 errata205
zarafa 7.1.12-49411
univention-spamassassin 6.0.1-5.73.201411121733
amavisd-new 1:2.7.1-2.43.201409242048

Vielen Dank.

Mit freundlichem Gruße,


#2

Moin,

Zum Dateiort: /etc/mail/spamassassin ist nur ein symbolischer Link auf /etc/spamassassin. Sie haben also doch nur eine local.cf.

Die local.cf ist eigentlich auch der richtige Ort dafür. Beachten Sie aber, dass die Optionen darin wohl komplett klein geschrieben sein müssen (Sie haben in Ihrem Beispiel ein großes B) – zumindest sagt die man-Page »man Mail::SpamAssassin::Conf« nichts Gegenteiliges.

Achten Sie weiterhin darauf, dass Sie die Option nicht versehentlich innerhalb eines »ifplugin…«-Blocks stehen haben und das dort abgefragte Plugin nicht aktiv ist.


#3

Danke. Ich habe den Fehler gefunden.

Ich habe schlicht den Amavis Dienst nicht neugestartet. Sobald dies geschehen ist, greift der blacklist Eintrag.

Mit freundlichem Gruße,


#4

Ach ja, der beliebte Neuladefehler… den verbocke ich auch oft genug :wink: