[SOLVED] UVMM Windows 10

Hello,

I am trying to install a win10 guest using uvmm and have tried using several different images. I found this post in German that defines exactly what I am going through. The iso boots, but hangs at the windows icon and never continues. Since this is an older post, I was wondering if there was any other workarounds/fixes, etc.? Is the fix discussed in this post the best way to approach the issue?

Hi,
to be honest I didnt install any win10 on UVMM anymore since then.
We are still using Univention, but use Proxmox for virtualization instead.

Are you using the newest UCS (4.4-0) ?
Hard to believe that they didn’t fix this in the meanwhile, but what do I know? :wink:

Cheers,
Roland.

Do you have a separate machine for Proxmox? We are using the current UCS build. I, too, am surprised the issue hasn’t been addressed. My initial thinking was that I was doing something wrong. But Virtualization is so easy with other distros, I was quite stumped when I came across this issue.

Yes, sure.
We have one or more bare metal proxmox machines at the customers (depending if they want HA) and run Univention and all the other machines as VMs.

Usually KVM is a great linux tool, but running it with the integrated UCS solution was always very challenging.

For example: do you make an own domain for the KVM hosts or not?
If you want the hypervisor in the same domain you need to make some hacking to have the UCS master be a virtual machine (which is usually what you want).

I wouldn’t use UVMM in a productive environment anymore, if I can prevent it.
But that’s just my personal opinion.

For your problem: I suggest that you ask in the original thread you mentioned. Maybe someone else can help you who has some recent UVMM experience.

I thought I would share the solution as it was really quite simple, but took some digging.

First, I found this bug report.
In it, there are some instructions that are a little hazy, so I thought I would clear them up (please correct me if I’m wrong).

  1. You need to find out what your CPU model is: virsh capabilities | grep <model>
    in my case, I have two Intel Xeon E5620’s, model name is Westmere.

  2. You must confirm that your model has x86_64 capabilities: virsh cpu-models --arch x86_64

  3. Finally, you must edit the VM XML file: virsh edit $VM
    You can use virsh list to see the list of domains if you need.
    Philip Hahn, who originally posted the fix later added that the line added must be:

<cpu mode='host-model' />

I wasn’t 100% sure where to put this line, but after i added it the software moved it to the correct position. This solved the issue and allowed me to boot a win10-64 iso.

Glad, you solved it.
For some reason I thought this whole thread was a private conversation. :wink: