[Solved] Unable to Install UCS 4.2 in a KVM VM under Proxmox 4.4

virtualization
proxmox

#1

I’m trying to setup a UCS 4.2 VM under Proxmox 4.4 (KVM). The install proceeds normally through the Base System & Additional Software phases of the install but never reaches the System Setup phase. It halts with the following error message displayed:-

I have tried many variations of disk/NIC/display emulation as well as EFI & Bios boot but always arrive at the same point.

In /var/log/messages I see:-

May 29 07:59:28 unassigned-hostname systemd[1]: univention-system-setup-boot.service start operation timed out. Terminating.
May 29 07:59:28 unassigned-hostname systemd[1]: Failed to start LSB: Univention System Setup on boot.
May 29 07:59:28 unassigned-hostname systemd[1]: Unit univention-system-setup-boot.service entered failed state.

And so looking into /var/log/univention/system-setup-boot.log shows:-

/usr/share/univention-system-setup/startxwithfirefox has been started at Monday 29 May  07:55:30 AEST 2017
Started in 'init' mode

ln: failed to create symbolic link ‘/usr/lib/firefox-esr/browser/extensions/{e5bbc237-c99b-4ced-a061-0be27703295f}.xpi’: File exists


X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
Current Operating System: Linux unassigned-hostname 4.9.0-ucs103-amd64 #1 SMP Debian 4.9.13-1A~4.2.0.201703091358 (2017-03-09) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-ucs103-amd64.efi.signed root=UUID=b2f82ff2-d921-4875-a65a-e9d439693912 ro quiet loglevel=0 rootdelay=5 splash
Build Date: 11 February 2015  12:32:02AM
xorg-server 2:1.16.4-1 (http://www.debian.org/support) 
Current version of pixman: 0.32.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May 29 07:55:41 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
find: `/usr/share/gdm/themes/univention/': No such file or directory
1496008695800	addons.productaddons	ERROR	Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]
1496009066613	addons.productaddons	ERROR	Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]
1496009067569	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property

Has anyone experienced similar behaviour or can shine some light on this problem ?


#2

I meant to add that installing UCS 4.2 on the same bare metal box as is running Proxmox works fine with the same installation ISO. So I think I can safely rule out hardware or installation media faults. Seems like some problem/incompatibility between the UCS installer & Proxmox KVM.


#3

Hi tose,

I professionaly used a virtualized UCS cluster under Proxmox 4.4 and it works like a charm, so it’s not a Proxmox unmet dependency or environment.

I hope you’ll find a solution.

Regards


#4

For anyone who finds themselves in the same position, use of the “text mode” installer resulted in a successful installation without the issues I encountered above using the Graphical Installer.


#5

Just as a note: We use Proxmox together with UCS, in various combinations, from UCS3 up to UCS4.2, from PM3 up to PM5 (at time of writing PM5 is still beta), for several companies of various sizes, with and without support from Univention and/or Proxmox.
We never experienced any problem with the UCS installer, no matter textmode or graphical installer was used for installation as virtual machine in Proxmox.

So please check your UCS installation media (md5sums are ok?) or your proxmox configuration, or the configuration of the virtual machine (sufficient ram/cpu/hdd-image?)
https://docs.software-univention.de/installation-4.2.html#appliance:create:virt
https://docs.software-univention.de/installation-4.2.html#appliance:installbase
https://updates.software-univention.de/download/ucs-cds/ucs4.2-0/
http://updates.software-univention.de/download/images/md5/

Proxmox-specific help:
https://forum.proxmox.com/ or https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user or https://www.proxmox.com/de/training/video-tutorials or (if you own a subscription) https://my.proxmox.com/ or (if you need a local partner) https://www.proxmox.com/de/partner/reseller

hth, regards Lutz


#6

Thanks for the response Lutz. Yes, the MD5 checksum on my install media is correct.

I also have several UCS installations both for customers & myself. My experience has been that UCS 4.1 installations upgrade fine to 4.2, but fresh 4.2 installations have been problematic for me on Proxmox 4.4 using the graphical installer.

As far as the VM options you mention, I use:-

RAM: 512 MB - 6GB RAM range automatically assigned
CPU: Default (kvm64) with 1 socket, 2 cores
HDD: (Virtio) SCSI 32GB

I use raw disk images rather than qcow2 and my host filesystem is EXT4 LVM.

Anything of concern in the above that you can see?


#7

ok, let’s test your config, my system/config/vm for the tests:

root@XXXX:/mnt/pve/XXXX-nfs/template/iso# md5sum UCS_4.2-0-amd64.iso
d88b190e8d33d41101f89e10b3e64c70  UCS_4.2-0-amd64.iso

root@XXXX:~# pveversion
pve-manager/5.0-10/0d270679 (running kernel: 4.4.35-2-pve)

root@XXXX:~# cat /etc/pve/nodes/XXXX/qemu-server/XXX.conf
balloon: 512
bootdisk: virtio0
cores: 2
ide2: XXXX-nfs:iso/UCS_4.2-0-amd64.iso,media=cdrom
memory: 6144
name: ucs42.belug.de
net0: virtio=7A:10:45:EA:A8:1E,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsihw: virtio-scsi-pci
smbios1: uuid=2a55d7eb-b437-499a-b980-a36ffcaf39c6
sockets: 1
virtio0: XXXX-nfs:XXX/vm-XXX-disk-1.qcow2,size=32G

With this settings, i was able to install UCS4.2 without(^1) problems:

^1: to be honest: i had some problems with the english keyboard layout… thats all

Regards Lutz


#8

Here’s mine:-

root@pve:/var/lib/vz/template/iso# md5sum UCS-Installation-amd64.iso
d88b190e8d33d41101f89e10b3e64c70  UCS-Installation-amd64.iso

root@pve:/var/lib/vz/template/iso# pveversion
pve-manager/4.4-13/7ea56165 (running kernel: 4.4.62-1-pve)

root@pve:/etc/pve/nodes/pve/qemu-server# cat 101.conf
agent: 1
balloon: 512
bootdisk: scsi0
cores: 2
memory: 6144
name: UCS4Master
net0: virtio=06:56:B3:CD:D9:CB,bridge=vmbr0
numa: 0
ostype: l26
scsi0: local-lvm:vm-101-disk-1,size=32G
scsihw: virtio-scsi-pci
smbios1: uuid=f93977dc-000d-4cff-8c4f-d7c501f1427d
sockets: 1