[solved] Can't enable 2Factor Auth on Nextcloud



Hello all,

we using Nextcloud 15.0.8 on UCS 4.4. So we installed the officially 2Factorplugin “Two-Factor TOTP Provider”. But it can not be activated. You can click on the checkbox, but the enableprocess never ends.

On my other nextcloud installation on Ubuntu it worked normally. So is this issue known. Or there are useable logs that say me what i have to do?

Thanks and best Regards


I am newbie in using UCS and so I am making my experiences by trial and error the last three weeks.

One day I had the problem, that I couldn’t login into nextcloud and could not call any item in Univention management anymore. After increasing the virtual RAM (hint in annother thread of this forum) of my UCS-VM by 1GB everything worked fine again. - The more Univention Apps or packages you install the more memory seem to be needed.

So I guess, that the never ending enable-process may be the result of too less memory which may result to loss of connection to the server services. - If possible, try by increasing the memory of the VM by 512 MB and try again.

Maybe you can find a hint in the logs:


Thanks for your answer. But

              total        used        free      shared  buff/cache   available
Mem:           3951        1315        1010          73        1626        2199
Swap:          8189           0        8189

So memory enouth. I checked up the logs, but there is nothing helped me find out why it doesn’t work.


It works no. But i can’t say why. I think there was another firewallrule between virtual domains. :slight_smile: :slight_smile: