Smbd not installed with fresh UCS install. Manual install causes followup problems

UCS version: 5.0-7 errata994.

Hi! after a week of trying to find a solution for this problem and not getting anywhere, I figured my next best attempt would be to make a post here.

I am currently working on migrating a Filesystem into UCS, allowing it to be accessable via samba. since i already use UCS, it made sense to use the built in shares function, to make sure everything works i created a separate UCS for testing.
On install, i noticed that smbd is not installed, nor are the samba ports open.
I am still able to create shares using the web interface, however trying to verify these is impossible as i cannot connect to the non-existing samba ports.
Upon manually installing smbd (apt install samba) I noticed that ucs-install does not recognise samba, smb or smbd.

Following a manual install and verifying that UCS is pointing to the right directories, i tried t create the shares again with a new user, and try to connect to the share with this new user. Sadly, this is not possible from a remote machine, nor is it possible locally.
Trying to debug why, i check the config of smb (/etc/samba/smb.conf) and make sure its the same config as UCS, i noticed the config file was never touched by UCS.

Any share changes i tried to make are not reflected in the samba config, nor is it possible for any user to connect to these shares. The smb config is still the same default config you get on a fresh install.
I highly doubt this may be the issue, but do i need to modify the smb.conf file by hand, rather than using the shares webpage?

From all my other searches, i can find people having no issues with samba installations.
Is there anything missing or something that went wrong? Am I missing a configuration step that lets samba install properly that i didn’t see in the manuals?

A couple of things to consider here:

  1. UCS uses metapackages to provide appropriate integration and configuration for services like samba.
  2. Installation of packages should be done with univention-install to use the recommended options for apt.
  3. UCS has a concept of server roles. Some packages are only suitable for installation of particular roles.
  4. For high level installation of services it is recommended to use univention-app which takes the server role of the particular system into consideration. e.g. univention-app list can be used to see what apps are available (and where they are installed in the domain).
  5. To be able to run SMB fileserver services, at least one system in the domain needs to serve as AD domain controller. To achieve that univention-app install samba4 can be run, e.g. on the UCS Primary Directory Node. That system is then automatically able to serve files (e.g. the sysvol for GPOs).
  6. Redundancy can be increased by installing the samba4 app on additional UCS Directory Nodes (of role Backup or Replica).
  7. Pure fileservers (without AD DC functionality) can be joined by installing by running univention-app install samba-memberserver on UCS Managed Nodes (aka memberservers).
  8. UCS has a domain management approach that is based on the Unviention Directory Manager (frontend for OpenLDAP) and a Web management interface Univention Management Console. File shares can be configured there and are then persisted in LDAP and replicated into smb.conf configuration (via included subfiles) on the respective nodes. Univention Corporate Server for Debian and Ubuntu Administrators — UCS 5.0 for Debian and Ubuntu Administrators may be interesting if new to these concepts.
1 Like