SMB Problem Ricoh MuFu "RICOH MP C4503"



bis zu einem UCS 4.3 Update in den letzten Wochen konnte o.g. Ricoh problemlos Scan-Dateien in einem Sahre auf dem UCS 4.3 Drucker ablegen. jetzt kommt ein “Autorisierungsfehler”

Wurde da aktuell am Samba etwas geändert? Protokoll? Sicherheit?





we prefer English meanwhile here.

So you updated your UCS recently and your multifunctional printer/scanner can not access a share for the can files any more?

As I do not know your environment have you tried so use the search feature here?


There might be some more. Try searching for ntlmv1 which might be related, too.



Most likely it is caused by ntlmv1 authentication being disabled by one of the samba upgrades. Read about the consequences (“Bundestags hack”?) and then set

root@server:~# ucr set samba/ntlm/auth=yes

because Ricoh does not provide an upgrade.



@crbble: you are right, this might fix the issue. But I would strongly advise against setting it to “yes” (aka NTLMv1). NTLMv1 is outdated since years and has so many security flaws.

@zash: If it is just for a home environment with a single user it might be fine.

But in all other cases it should be set to “no”.

If the printer does not get any further updates and is not able to “talk” NTLMv2 it might be out of any maintenance and already several years old- perhaps it will break anyways in the next couple of months.

Buy a new one…



“Buy a new one” is not the solution for small businesses, where several thousand Euros are already a big investment.

Minor upgrade on the issue itself, after several mails and phone calls with Ricoh they send a technician, who upgraded the software on our C2503 device. This did not fix the issue though, there is a guide on the internet that shows how to explicitly enable NTLMv2 authentication via telnet [sic!]. It works now. Ricoh may charge you for the this.