Sichtbarkeit von [homes] Freigaben

german

#1

Hallo!

Wir sind von einem Zentyal domain controller auf UCS migriert.
Es hat alles wunderbar geklappt, lediglich ein Verhalten von UCS konnte ich nicht wie gewünscht ändern, so dass es zum von Zentyal gewöhnten Verhalten passt:

Die Freigaben der Benutzerverzeichnisse sind von Haus aus nicht sichtbar, sondern müssen explizit angewählt werden. Alle weiteren shares sind wie gewünscht sichtbar.
Dies ist sowohl unter Windows- als auch Linux- und Mac clients der Fall.

Beispiel:
Server: UCS
User: testuser

Share \UCS\testuser ist erreichbar, aber nicht in \UCS sichtbar.

Ist es möglich, dieses Verhalten so zu ändern, dass die Benutzerverzeichnisse sichtbar sind?

Danke und viele Grüße!


#2

Moin,

das kann in UCS momentan leider nicht konfiguriert werden; das ist aktuell hart in der Konfiguration vorgegeben. Sie können es manuell ändern. Dazu müssen Sie auf dem Fileserver das Template anpassen, aus dem die Datei /etc/samba/base.conf erzeugt wird. Das Template ist /etc/univention/templates/files/etc/samba/base.conf. Hier müssen Sie im Teil, der die Share »homes« erzeugt, den Parameter »browsable« aus »yes« setzen, danach die Datei /etc/samba/base.conf mit dem Befehl »ucr commit /etc/samba/base.conf« neu erzeugen und anschließend den Samba-4-Dienst neu starten (z.B. »service samba-ad-dc restart«… der eigentliche Service hängt von der Domänensituation ab; zur Not einfach ein Reboot).

Beachten Sie, dass solche Templateänderungen bei Upgrades zu Problemen führen können. Sie sollten daher nach jedem Upgrade mit dem Befehl »univention-check-templates« prüfen, für welche Templates es zwar lokale Änderungen aber auch neue Dateien von Univention gibt.

Die richtige Lösung wäre, im Univention-Bugtracker einen Featurewunsch zu eröffnen, dass diese Einstellung z.B. über eine Baseconfig-Variable konfigurierbar gemacht wird. Das wäre eine triviale Änderung, die dann auch upgradesicher wäre.


#3

Hallo!

Danke für die Antwort!

Leider war ich bereits vorher so weit, die Lösung ist leider nicht korrekt.

Die “[homes]” section von samba ist ein wenig speziell. Wenn die shares browseable gemacht werden, wird ein nicht erreichbares share namens “homes” sichtbar gemacht.

Ob home shares browsable sind, wird laut samba doku vom globalen browseable flag vererbt, und das ist per default “true” und wird auch von ucs nicht auf false gesetzt.

Die Lösung muss irgendwo anders liegen…


#4

Hmm, guter Punkt. Leider habe ich beim Suchen danach allerdings keinerlei Anhaltspunkte gefunden, die das von Ihnen gewünschte Verhalten ermöglichen – entweder, das wollen zu wenig Leute, oder es geht schlicht nicht, ohne für jeden vorhandenen User eine eigene Share anzulegen.

Wenn Sie noch die Konfiguration vom alten Server haben, so würde ich empfehlen, in der nachzuschauen, was die so an Einstellungen beinhaltet; gerne auch hier pasten.


#5

Vielen Dank für Ihre Hilfe!

Ich habe schon während der Einrichtung die samba Konfiguration zwischen dem Zentyal System und UCS verglichen, und keine hilfreichen Unterschiede gefunden.

Die Konfiguration der homes section habe ich versuchsweise übertragen, ohne Erfolg.
Die Konfiguration der global section unterscheidet sich deutlich, jedoch nicht, was browseability angeht.

Der Teufel scheint ziemlich tief im Detail zu stecken.


#6

Bevor ich das Problem als “wontfix” abhake:

In der [global] section gibt es eine Option, zu der ich keine Dokumentation finde, und die evtl. etwas damit zu tun haben könnte:

“nmbd_proxy_logon:cldap_server=127.0.0.1”

Gibt es dafür irgendwo doku?
Kann das dafür sorgen, dass nmbd das home share nicht broadcastet?


#7

Kann sein, dass es eine der Univention-Erweiterungen ist. Allerdings hat das mit 99,9%iger Sicherheit nichts mit Ihrem Problem zu tun. Der nmdb ist nur für die Namensauflösung via NetBIOS zuständig (NetBIOS name server daemon) und stellt optional den WINS-Server für das lokale Netz. Sprich wenn ein Client im Netz nach dem Namen »master« sucht und dafür nicht DNS sondern NetBIOS nutzt, genau dann kommt der nmbd ins Spiel.

Der nmbd hat aber reing ar nichts mit Freigaben zu tun.


#8

Das Problem hat auch nichts mit der Freigabe zu tun, die ja korrekt bereitgestellt wird.

Sie ist nur nicht sichtbar, und ich dachte, dafür wäre der der nmbd zuständig.

Danke für die Aufklärung!