Self service errors


I performed search of similar issue on forum, but could not find the identical one.
That is why I have created the topic and hope somebody would be able to help me.

We are going to use the embedded self service password reset of UCS.
Unfortunately, I am getting the following error message when I try to reset my password:

It is weird because all emails and contact data are specified in settings of account.

Besides that, if I try to use self service ‘Protect Account’ I get this error:

We use UCS 4.2.
UCR parameter ‘umc/self-service/passwordreset/blacklist/groups’ is empty.
Parameter ‘umc/self-service/passwordreset/whitelist/users’ has value ‘*’

Log files of UCS contain the same information that is visible on messages.

Could you point me what I have missed in setting up self service password reset and how this could be resolved?

Thanks in advance.


you need to specify an (external) email address or mobile # in the ‘Password recovery’ section of the user.

Thanks for the reply.

‘Password recovery’ section was filled in by corporate email. Just for checking your suggestion I changed email field by external mailbox, but this did not help. I still get the same error messages.

Hey there!

Looks like I have resolved the issue.
The problem was in incorrect settings of UCR.
The following parameters:

  • umc/self-service/passwordreset/blacklist/groups
  • umc/self-service/passwordreset/whitelist/groups

had wrong values.
And since my account had Domain Admins group as a primary group, I could not use the self service.

Sorry for inattentiveness.