Saslauthd (und IMAP4) bei Zarafa

german

#1

Hallo,

mir ist gerade aufgefallen, dass mein UCS (mit Zarafa) beim Systemstart eine Warnmeldung ausgibt, dass saslauthd nicht gestartet wird. Braucht das System den Dienst überhaupt oder muss der nur mit Kolab aktiviert sein?

Ausserdem waren bei mir IMAP4 und POP3 in der server.cfg vom Zarafa ausgeschaltet. Bug oder Feature? (Normal verwende ich das Webinterface oder Outlook, aber ein Postfach mit Statusmeldungen soll mit IMAP abgerufen werden…)

Gruss
Andreas


#2

Hallo,

soweit ich das aus meinen Aufzeichnungen noch zusammenbekomme, sollten Sie das Paket “univention-sasl” installieren, wenn Sie planen, mit Clients wie Thunderbird etc. Mails zu versenden. Das IMAP/POP-Gateway braucht den saslauthd vermutlich nicht, nur Postfix wird sich je nach Clientkonfiguration wohl beschweren.

Zur Konfiguration des Gatways selbst muß man angesichts IMAP and POP3 should be deactivated by default wohl auf “Feature” plädieren.

Viele Grüße,
Dirk Ahrnke


#3

Hallo Herr Ahrnke.

Wo könnte denn stehen, wann man das Paket installieren muss/sollte? Ich hab auf die Schnelle nix in der Doku gefunden.

Mich betrifft der Versand nicht, da ich wirklich nur die Statusmeldungen meiner Fritzbox per IMAP-Client sichten möchte. Ich mag die Sachen nicht in meinem regulären Postfach haben, oder diesen Posteingang zusätzlich einbinden. Dafür (und für 2 ‘Müllpostfächer’ bei GMX) nutzen meine Frau und ich Thunderbird. Mir ist die Meldung zu SASLAUTH nur aufgefallen, da ich gerade mal den Systemstart auf dem Schirm hatte.

Gruss
Andreas


#4

Hallo,

wenn Sie etwas sehen, dann wahrscheinlich nur in /var/log/mail.log und nach meiner Erinnerung im Moment auch nur, wenn via Port 465 versendet wird.

Der Status der Dokumentation zum Thema ist mir selbst gerade unklar. Ich werd mir das in den nächsten Tagen noch mal vornehmen.

Viele Grüße,
Dirk Ahrnke


#5

Ich habe meine Sicht des Problems gerade in [bug]33143[/bug] formuliert.


#6

Bei einer UCS 3.2 Installation ist mir gerade ein ähnliches Problem begegnet.
Bisher lief saslauthd immer problemlos, seit Monaten konnten Mails via 465 und LOGIN versendet werden. Nach dem Update auf errata-125 und dem folgenden Neustart wurden keine Mails mehr angenommen.
Ein Neustart von saslauthd brachte keine Besserung, erst die Änderung von START=NO auf START=yes in der /etc/defaul/saslauthd.

Die Fehlermeldung aus /varlog/mail.log lautete

 SASL Authentication failure: cannot connect to saslauthd server: No such file or directory 

#7

Hallo,

bei mir steht univention-sasl_2.0.0-1.6.201309241140_all.deb als aktuelles Paket. Das originale Template würde einen automatischen Start bewirken.

root@mail:~# ls -l /etc/univention/templates/files/etc/default/saslauthd -rw-r--r-- 1 root root 1994 8. Sep 2011 /etc/univention/templates/files/etc/default/saslauthd root@mail:~# grep START /etc/univention/templates/files/etc/default/saslauthd START=yes

Viele Grüße,
Dirk Ahrnke