Samba wants to create pso in "Password Settings Container"-Container

Hi Guys,

I’m working on a Univention 4.4-8 and samba4.1.0-1.
I need to create a PSO in sambaLDAP just for a few users so i tried it with the samba-cli command:

samba-tool domain passwordsettings pso create PwPolicyUser 1 --min-pwd-length=8

The output of that command is “Failed to create PSO “CN=PwPolicyUser, …”: objectclass: Cannot add CN=Password Settings Container,CN=System,DC=my,DC=domain, parent does not exist!”

When I try to manually enter an Container for the PSO something like:

samba-tool domain passwordsettings pso create "CN=PwPolicyUser,DC=my,DC=domain" 1 --min-pwd-length=8

I get a “ldb_search: invalid basedn ‘(null)’”-Error.
I tried check Join-Status -> Everythings OK and join-scripts are skipped.
Also I checked the Server for Kerberos Problems -> kinit issues tickets successfully

Anyone already had a similar issue?

Edit.: When searching with ldbsearch i dont find this “Password Settings Container”-Container. But on other Servers this Container exists in Samba (ldbsearch).

Regards,
Raphael

To clarify my colleagues post:
This command returns zero entries:

ldbsearch -H /var/lib/samba/private/sam.ldb cn='Password Settings Container'

which isn’t the default behaviour. The parent (CN=System,DC=company,DC=at) exists.
What is the univention way to (re-)create this container?

Roland.