Samba über OpenVPN

german

#1

Liebes Forum,

der Zugriff auf Samba-Shares über OpenVPN funktioniert nicht.

smbclient -L auf die VPN-IP des Servers meldet NT_STATUS_CONNECTION_REFUSED

Der Server ist pingbar, und andere Dienste lassen sich normal aufrufen.

Aus dem LAN können sich alle Clients normal verbinden.

OVPN Zugriff auf Freigaben ist bekannt, aber ein Routing/DNS-Problem würde ich ausschließen.

Dankbar für Hinweise,
Daniel Tippmann


#2

Darf ich fragen warum? Sind ggf. nicht die richtigen Ports freigeschaltet oder kann es sonstige Firewall Probleme geben?


#3

Ich verstehe nicht ganz… Clients verbinden sich über OpenVPN (4UCS) mit dem Server und können dann nicht über die VPN-IP des Servers auf die Samba-Freigaben zugreifen. Eine Firewall sollte da nicht dazwischen sein.

Die Fehlermeldung deutet m.E. darauf hin, dass Samba sehr wohl antwortet, die Ports also offen sind. Vielleicht haben Clients aus dem VPN-Subnetz keine Berechtigung; evtl. hilft eine hosts.allow-Regel. Was wäre in UCS der richtige Ort dafür?

Danke und Gruß,
D. Tippmann


#4

Hallo Daniel,

nur weil der Port offen ist, heißt es nicht, dass samba darauf arbeitet.

Ich vermute es hängt damit zusammen, dass tun0 nicht broadcastfähig ist, und samba es daher per default ignoriert:

[code]man smb.conf

interfaces (G)
This option allows you to override the default network interfaces list that Samba will use for browsing, name registration and other NetBIOS over TCP/IP (NBT) traffic. By default Samba will query the kernel for the list of all active interfaces and use any interfaces except 127.0.0.1 that are broadcast capable.[/code]

Vielleicht klappt’s mit:

ucr set samba/interfaces="lo eth0 tun0"

Es könnte auch sein, dass “bind interfaces only” an ist. Der default ist “off”, daher:

ucr unset samba/interfaces/bindonly

Wenn es auch so nicht klappt, müsste eine route zur eth0-IP im openvpn-client die Verwendung selbiger zur Verbindung zu samba helfen (kann vom openvpn-server zum client gepusht werden).

Gruß
Daniel


#5

Hi Daniel,

OK fürs Protokoll: Über die Interface-Settings ließ sich Samba nicht zur Arbeit übers VPN bewegen.

Mit der Route klappt’s, auch wenn das natürlich potentielle IP-Adresskonflikte mit sich bringt.

Trotzdem vielen Dank, Daniel! :slight_smile: