Samba (shares) not working after update to 5.2

Hi,
after updating UCS to 5.2-1 samba is not working anymore.
No shares are accessible from other machines in the network.

When checking system services i noticed that neither heimdal-kdc nor samba4 are running. When trying to start them via the web interface it throws an error that /etc/init.d/samba is not available (which is true there only exists /etc/init.d/samba-ad-dc).

I dont know if this might be related but we changed password_encryption method of postgres15, which probably was an error because we do not know hot set passwords again…

Grateful for any hint how to probably fix this,
Christian

have you gotten anywhere? i have the same issue. no shares are available (besides sysvol and netlogon)