Samba Access Problems


#1

Hi This is my error from a client:

smbclient //IPUCS/dir -U user
WARNING: The "syslog" option is deprecated
Enter user's password: 
session setup failed: NT_STATUS_IO_TIMEOUT

What is the problem?


#2

it is really hard to provide an answer without further hints about the usecase, the configuration and things you tried yourself.

The only information I have at this is that it works for me when I try this on the server itself.


#3

This is my asset:
1 UCS Server
2 different nfs server

I’ve mount nfs dir on UCS:

IP_nfs_server:/dirt /mnt/dir nfs rsize=32768,wsize=32768,intr,noatime,actimeo=0,timeo=7,intr,tcp,acl 0 0

Then I’ve shared /mnt/dir by /univention-management-console/?lang=en-US#module=udm:shares/share:0:

getfacl /mnt/dir
getfacl: Removing leading '/' from absolute path names
# file: mnt/dir
# owner: root
# group: root
user::rwx
group::---
other::---

Then I want to set read/write permissione to mnt/dir XYX Group.
I’ve use univention-management-console “share Settings”?

This is error:

smbclient //IP_UCS/dir -U user
WARNING: The "syslog" option is deprecated
Enter user's password: 
Domain=[**********] OS=[Windows 6.1] Server=[Samba 4.5.1-Debian]
smb: \> dir
NT_STATUS_ACCESS_DENIED listing \*
smb: \> 

#4

The last smbclient output indicates that “User” has no permission to the share “dir”.
The getfacl output only shows access for root.
You need to adjust the Samba permissions, basics are described in 11.2. Management of shares in UMC.

hth,
Dirk


#5

User x is on GroupX
I want to share dir with GroupX r/w

I’ve set this:

Directory owner of the share’s root directory: root
Directory owner group of the share’s root directory: Domain Admins
In Samba Permissions:
Restrict write access to these users/groups: GroupX

—> same error


#6

Hello,

is this helpful: forum.univention.de/viewtopic.p … 40&p=23277 ?

Regards,
Jens


#7

I’ve read post.

I’ve set permissions but same error

Wher can I see lgos about?


#8

The relevant logs should be the samba logs at: /var/log/samba/log.smbd or /var/log/samba/log.samba - maybe you can find something under /var/log/syslog - to narrow the timeframe down, try an access and note the timestamp. Then search in the range of +/- 5 Seconds around that timestamp. You can change the Loglevel by using the following UCR Variable:

ucr set samba/debug/level=4

you should set it lower again after your debugsession.


#9

I’ve problems about sharing dir: my dir have root:Domain Admins owner. How can I reserve access only to 1 group?


#10

Is the documentation at this point helpful?

docs.software-univention.de/man … s::general

Kind regards,
Jens Thorp-Hansen