S4connector auf DC Slave

german

#1

Hallo,

opsi bringt ja als neue Abhängigkeit den s4connector mit, d.h. daß dieser nun auch auch DC Slaves installiert wird sofern opsi darauf läuft. Ich wollte mich hiermit noch mal selber vergewissern, daß mir das keine Probleme einbringt.

Danke und viele Grüße,
SirTux


#2

Hallo,
Wenn das joinscript des S4 Connectors (nach der Installation) durchläuft sollte es eine vorhandene S4 Installation erkennen (wenn bereits vorhanden) und keine PRobleme verursachen. Ich würde das in einer Testumgebung aber vorher verifizieren.

Gruß,
Jens Thorp-Hansen


#3

Es ist also weiterhin nicht vorgesehen und somit ungetestet?


#4

Richtig, wie der AD-Connector auch ist es eigentlich ™ nicht vorgesehen den auf einem Slave zu installieren und damit ungetestet (damit auch nicht supportet).

Gruß,
Jens Thorp-Hansen


#5

Danke, dann werde ich mal versuchen UIB davon zu überzeugen die Abhängigkeit wieder zu entfernen.


#6

Ich habe hierzu intern gerade noch einmal Rücksprache gehalten - laut meinen Informationen ist das Thema noch nicht komplett durch diskutiert und steht damit noch nicht fest - kann also sein, dass sich an den Abhängigkeiten noch etwas ändert.

Gruß,
Jens Thorp-Hansen


#7

Danke für die Information. Ich würde mich sehr freuen, wenn die Abhängigkeit wieder verschwinden würde. Ich habe ungern Dienste auf Systemen installiert, wo sie nach derzeitigen Stand niemals benötigt werden und eventuell Schaden anrichten können. Ich werde dann opsi erstmal weiterhin nicht updaten.


#8

Hallo,
ich muss an dieser Stelle mit weiteren Informationen doch noch einmal meine gestrigen Aussagen korrigieren (lag glaube ich am Zuckermangel - Foot -> Mouth).

  • der S4 Connector kann auch auf Slaves installiert werden, es gibt hier ggf. nur ein Problem, wenn der Slave der einzige Samba4 Server in der Umgebung ist.
  • der S4 Connector kann mehrfach in einer Umgebung laufen. Zusätzliche Installationen erkennen bereits existierende S4 Connectoren und aktivieren sich dann ggf. nicht.

Zusammenfassend gesagt denke ich nicht, dass wir hier ein Problem haben oder bekommen werden.

Gruß,
Jens Thorp-Hansen


#9

Ok, dann werde ich das opsi-Update bei Gelegenheit doch mal einspielen.


#10

Ist das im Join-Script eigentlich so richtig oder ist das doch ein Tippfehler?

        if this_is_initial_or_rejoin \
                && this_host_is_not_registered_as_s4_connector; then
                ## Don't autostart S4 Connector on DC Backups.
                /etc/init.d/univention-s4-connector stop
                univention-config-registry set  connector/s4/autostart?no \
                                                connector/s4/listener/disabled=true
                /etc/init.d/univention-directory-listener crestart
        fi

Gemeint ist diese Zeile:

univention-config-registry set  connector/s4/autostart?no 

#11

Hallo,
wahrscheinlich ist das Fragezeichen gemeint? “autostart?no” heisst, an dieser Stelle wird die Variable nur gesetzt, wenn Sie einer festgelegten Vorbedingung entspricht.
Gruß,
Jens Thorp-Hansen


#12

Ja danke das war gemeint :wink:


#13

So ich habe das Upgrade durchgeführt. Erfreulicherweise gabs keine Komplikationen :slight_smile: