S4 Connector Reject Object locked

samba-ad
s4-connector

#1

Hi everyone,

i hope this will be a short Topic :wink:

Following 2 Rejects:

9.06.2017 10:06:44,294 LDAP        (PROCESS): sync from ucs:   Resync rejected file: /var/lib/univention-connector/s4/1494250156.869508
29.06.2017 10:06:44,295 LDAP        (PROCESS): sync from ucs: [         group] [       add] CN=Server Operators,cn=builtin,DC=company,DC=local
29.06.2017 10:06:44,300 LDAP        (PROCESS): Unable to sync CN=Server Operators,cn=builtin,DC=company,DC=local (GUID: 5f151af3-8d17-427d-8802-5ce47cca3b3b). The object is currently locked.
29.06.2017 10:06:44,356 LDAP        (PROCESS): sync from ucs:   Resync rejected file: /var/lib/univention-connector/s4/1494250157.407681
29.06.2017 10:06:44,359 LDAP        (PROCESS): sync from ucs: [         group] [       add] CN=Replicator,cn=builtin,DC=company,DC=local
29.06.2017 10:06:44,363 LDAP        (PROCESS): Unable to sync CN=Replicator,cn=builtin,DC=company,DC=local (GUID: fff0f58d-3aa1-4542-9806-f2b58be41a2c). The object is currently locked.

is it possible to remove this samba lock?

its an UCS@School environment and i got this 2 Rejects on 2 School slaves

Best Regards,
René


#2

I do not exactly know which version you use, but there are solved issues against 4.1 and 4.2 for this. The 4.1-4 one: https://forge.univention.org/bugzilla/show_bug.cgi?id=43247

You can also unlock the object via the following commands. But be aware, if yiu do not solve the underlying problem, these will just get locked again.

# service univention-s4-connector stop
# cp /etc/univention/connector/lockingdb.sqlite /etc/univention/connector/lockingdb.sqlite_OLD
# sqlite3 /etc/univention/connector/lockingdb.sqlite 'SELECT * FROM S4_LOCK;'
# sqlite3 /etc/univention/connector/lockingdb.sqlite 'DELETE FROM S4_LOCK;'
# sqlite3 /etc/univention/connector/lockingdb.sqlite 'SELECT COUNT(*) FROM S4_LOCK;'
# service univention-s4-connector start

#3

Thanks,

but what are these ‘underlying problems’ which causes the s4-lock?
As i told you some days ago, ‘There are no meaningful failure messages’ :smiley:


#4

Solved it for now, thanks :slight_smile: