RPC Server nicht verfügbar

german

#1

Hallo zusammen,

vor ein paar Tagen habe ich mir einen UCS aufgesetzt und alles hat wunderbar funktioniert.
Heute bekomme ich beim Aufruf verschiedener AD-Tools (Gruppenrichtlinien & Benutzer) die Meldung, der RPC wäre nicht verfügbar und ich solle doch bitte einen anderen DC auswählen.
Alle anderen Funktionen sind noch intakt. Kann mich als Benutzer anmelden, Netzlaufwerke funktionieren, GPO wird ausgeführt, Webinterface läuft.

Da ich keine (mir bekannte) Veränderung vorgenommen habe, bin ich erst mal hingegangen und habe alle beteiligten Systeme neu gestartet. Im Web-Admin bemerkte ich dann ausstehende Updates - habe diese gleich mal installiert. Hätte ja helfen können…

Systemfehlerdiagnose meldet keine Probleme, Alle Dienste außer Kerberos sind gestartet,

Noch mal der Vollständigkeit halber:

  • UCS als PDC
  • DNS aktiviert und funktioniert
  • Aktuellste Version
  • Client ist ein Win7 (momentan einziger Rechner in der Domäne)
    Fehlt was?

Hat jemand eine Idee?
Bei meinen Recherchen bin ich auf zwei ähnliche oder gar identische Problem-Meldungen gestoßen - leider ohne Lösung.
Hat jemand eine Idee?

Besten Dank & viele Grüße,
Rudolf


#2

Hallo,

Nein, das klingt vernünftig - ich habe die genaue Fehlermeldung nicht verstanden, aber es läuft auch ein Gegenstück für die RPC-Kommunikation auf dem Windows Client, Stichwort Remoteprozeduraufruf. Eventuell macht es Sinn den Client einmal neu zu joinen, wenn auf auf dem Server selbst nichts auffällt.

Mit freundlichen Grüßen,
Tim Petersen


#3

Diese Idee kam mir auch bereits…
Grundsätzlich läuft der RPC Dienst auf dem Client einwandfrei (sprich er startet ordentlich und ohne Fehler im Log).

Wollte dies soeben ausprobieren - dabei ist mir aufgefallen, dass ich mich nicht mehr an der Management Console anmelden kann.
Die Fehlermeldung lässt sich leider nicht ganz lesen, da das Anmeldefenster im Vordergrund steht. Scheint aber eine 503-Meldung zu sein:

Grundsätzlich noch mal zum ursprünglichen Fehler: der Client konnte den RPC Dienst (wird vom Samba bereitgestellt) nicht erreicht. Bei Windows Server liegt das meist daran, dass der RPC Dienst auf dem Server nicht läuft oder WINS auf dem Client nicht korrekt eingerichtet wurde…

Bin gerade etwas verunsichert, wie ich weiter machen soll?!
Erstmal den 503 ergründen oder im RPC-Fall weitermachen…?
Hat jemand vielleicht eine Idee, was dem Webserver fehlen könnte? Äußere Faktoren sind relativ unwahrscheinlich, das der Server noch lange nicht produktiv eingesetzt wird.

NACHTRAG: ein reboot des Servers hat bezüglich des 503 erst mal geholfen


#4

Das Entfernen aus der Domäne funktionierte noch.
Das wieder einhängen schlägt fehl:


#5

ui ui ui

Befürchte, ich habe eine mögliche Fehlerquelle gefunden.
Es scheint, als wäre der als “stand-alone” deklarierte Application-Server (wird von einer externen Firma gewartet) ein Domänen-Controller.
Und ja - die Domäne hat die gleiche Bezeichnung wie der UCS :frowning:

Unter diesen Vorraussetzungen verwundert es mich, dass ich überhaupt so weit habe kommen können!
Als proof of concept werde ich heute Abend den alten - eh nicht als solchen eingesetzten - DC vom Netz nehmen und prüfen, ob es daran lag.

Schätze, ein Umbenennen der UCS Domäne wird nicht vorgesehen sein?

NACHTRAG: nachdem der rogue DC vom Netz genommen wurde komme ich mit dem join leider auch nicht weiter (Fehlermeldung bleibt die gleiche)


#6

Hallo,

ich würde unter diesen Voraussetzungen eher das UCS-System und damit das S4 neu installieren - alternativ können Sie das S4 auch re-provisionieren:
Re-Provisioning Samba4 on a DC Master

Eine konkrete Analyse und eventuelle Aufräumarbeiten halte ich in der geschilderten Situation und unter der Prämisse, dass es sich um ein Testsystem handelt, nicht für sinnvoll - schauen Sie für generelles Samba 4 Troubleshooting aber gern auch:
Samba 4 Troubleshooting

Mit freundlichen Grüßen,
Tim Petersen