Rootfs kernel options ändern

german

#1

Hallo,

ich möchte das rootfs, welches vom Kernel gebootet wird, ändern, hierzu habe ich folgende ucr variable geändert:

Reboote ich nun die Maschine, passiert nichts, es wird trotzdem das alte rootfs bei den kernel-optionen angezeigt??

Wie gehe ich richtig vor?

ps.: es handelt sich hierbei um eine kvm virtualisierten gast.

lG


#2

Hallo,

auf einem UCS 2.4 (grub1) System können Sie wie von Ihnen beschrieben vorgehen, um das rootfs zu spezifizieren:

ucr set grub/root="/dev/sdX"

Unter UCS 3.0 (grub2) müssen Sie hier aufgrund der Anpassungen in grub2 ein wenig anders vorgehen.
Setzen Sie hierzu bitte die UCR-Variable “grub/append”, welche verwendet wird um weitere Kernel-Optionen anzugeben:

ucr set grub/append="root=/dev/sdX"

Sollten hier bereits Kernel-Optionen gesetzt sein, so erweitern Sie die Variable bitte entsprechend:

ucr set grub/append="splash=silent root=/dev/sdX"

Beachten Sie hierbei bitte, dass Sie auf einem UCS 2.4 System ebenfalls die Möglichkeit haben, die UCR-Variable “grub/append” zu verwenden (um ggf. weitere Kernel-Optionen zu übergeben).
Sollten Sie an dieser Stelle sowohl “grub/root” als auch “grub/append” zur Spezifizierung des rootfs verwenden, so wird stehts die zuletztstehende Option verwendet.
Hierzu ein kurzes Beispiel:

ucr set grub/root="/dev/sda1" ucr set grub/append="root2fstype=ext3 splash=silent root=dev/sda2"
Führt zu folgender cmdline:

/vmlinuz-2.6.32-ucs48-686-bigmem root=/dev/sda1 ro root2fstype=ext3 splash=silent vga=791 loglevel=0 root=/dev/sda2

In der Folge würde hier “/dev/sda2” als rootfs verwendet werden.

Mit freundlichen Grüßen,
Tim Petersen


#3

Hallo,

wie ich im ersten Beitrag geschrieben habe, bewirkt der Befehl ucr set grub/root="/dev/sdX" keine Änderung und es wird immer noch das alte rootfs gebootet!


#4

Hallo,

könnten Sie uns einmal die Werte der entsprechenden Variablen zukommen lassen?

ucr search grub

Desweiteren wäre die Konsolenausgabe im Anschluss an ein:

ucr set grub/root="/dev/sdX"

interessant.

Mit freundlichen Grüßen,
Tim Petersen