Remove Kopano Webapp

kopano

#1

Hi all,

after Update to univention 4.3 I figured out several problems whit the kopano Webapp and try to uninstall Package by the Packagecenter.
Packagecenter also removed the Web App but I can still reach webapp.
So it seems the Package is not removed.
How can I purge the and make a clean install.
I tried univention-remove kopano-webapp then aptitude purge kopano-webapp but it seems aptitude is no longer present in univention 4.3.

Also whit a dpkg -l | grep kopano-webapp the parts are still on the system :frowning:

rc  kopano-webapp                                       3.4.2.1108+36.1                                  all          New and improved WebApp for Kopano
rc  kopano-webapp-plugin-delayeddelivery                2.0.0.6-7.1                                      all          Kopano WebApp Delayed delivery plugin
rc  kopano-webapp-plugin-desktopnotifications           2.0.1.0+12.1                                     all          Kopano WebApp Desktop notifications plugin
rc  kopano-webapp-plugin-filepreviewer                  2.0.0.15+10.2                                    all          Kopano File previewer plugin
rc  kopano-webapp-plugin-files                          2.1.0.222+34.2                                   all          Adds Files functionality to Kopano enabling access to WebDAV and other files backends.
rc  kopano-webapp-plugin-mdm                            2.1.0.66+19.1                                    all          Kopano WebApp MDM plugin
rc  kopano-webapp-plugin-meetings                       3.0.1.100                                        all          Kopano WebApp Meetings Plugin
rc  kopano-webapp-plugin-smime                          2.1.1.77-9.1                                     all          Kopano WebApp S/MIME plugin
rc  kopano-webapp-plugin-spell                          2.0.0.2+10.2                                     all          Kopano WebApp Spellchecker plugin
rc  kopano-webapp-plugin-titlecounter                   3.4.2.1108+36.1                                  all          Kopano WebApp Titlecounter plugin
rc  kopano-webapp-plugin-webappmanual                   3.4.2.1108+36.1                                  all          Kopano WebApp Manual plugin
rc  kopano4ucs-webapp 

Best C.


#2

Hey Carmen,

that’s normal — rc means that the program files have been removed, but that the configuration files are still present. That’s how Debian packages work; configuration files are usually left in place in case the admin needs to save custom adjustments to them.

You can purge them easily with dpkg -l | awk '/kopano.*webapp/ { print $2 }' | xargs -r dpkg --purge Afterwards they should be gone completely.

Kind regards,
mosu


#3

@Moritz_Bunkus

Thank you Moritz, that worked for me.
Unfortunately the reinstall does not solve any partial reported problem in the Webapp.

  • Still the MDM Plugin is not working, so it’s not possible to add folders throug the MDM Plugin

  • Some users have the spellchecker but it’s not working and the others can’t see them.
    2

  • Mail settings, in Accounts of some users it’s not possible to change anything. There is no possibility to store changes, the only possibility is to aboard the process.
    If pressing “save siganture"Anwenden” as a example, it does nothing.
    If you klick on a other part to do configuration it shows a pop up and you can only klick on no.
    signature

I don’t know what to do to fix this things in case it seems it’s based on some accounts and not every account has the same issue.

Best C.