Remote logging UCC3

german

#1

Hallo,
bei uns funktioniert das im Handbuch beschrieben “Remote logging” leider nicht.
Das Verzeichnis “/var/log/univention/ucc-clients” ist zwar vorhanden aber einfach leer.
“Univention Configuration Registry variable” sind nicht gesetzt und auch wenn diese direkt auf den UCS zeigt, ändert das nichts.
Ob dieses Verhalten erst mit dem UCC3 eingesetzt hat, kann ich nicht sagen.
Bei uns bleiben gelegentlich (viel zu oft) die UCC3-Clients einfach stehen, so als wäre der Prozessor überhitzt. Nichts geht mehr, außer reset.
Dieses Verhalten wollten wir nun genauer untersuchen.


#2

Hallo,

Gab es hier schon eine Lösung? Ich hätte aus verschiedenen Gründen gerne die Logs zurück auf dem Server, habe mich selbst aber noch nicht tiefer hineingearbeitet.

Ideen?

Liebe Grüße…


#3

Hallo,

wenn ich mir [bug]42009[/bug] ansehe, scheint es ja grundsätzlich zu gehen (nur eben schlecht zu deaktivieren).

Mit der Installation vom UCC wird die Syslog-Konfiguration erweitert:

[code]root@master:/etc/rsyslog.d# cat ucc.conf

Activate the reception of remote logging via UDP

$ModLoad imudp
$UDPServerRun 514
$template DynaFile,"/var/log/univention/ucc-clients/syslog-%HOSTNAME%.log"
:inputname, isequal, “imudp” ?DynaFile
& ~

Activate the reception of remote logging via RELP

$ModLoad imrelp
$InputRELPServerRun 514
$template DynaFile,"/var/log/univention/ucc-clients/syslog-%HOSTNAME%.log"
:inputname, isequal, “imrelp” ?DynaFile
& ~
[/code]

Das hatte in meinem System zur Folge, dass auch von Nicht-UCC Systemen Logs einsortiert werden. Ich finde das z.B. jetzt die Logs vom Router bei dem ich Remotelogging aktiviert hatte…
Jedenfalls könnte man so testen, ob es an den Clients oder der Serverkonfiguration liegt.

Viele Grüße,
Dirk Ahrnke


#4

Hallo Dirk Ahrnke,

danke für die Antwort und entschuldige bitte die späte Reaktion!

Ich habe nun gesehen, dass Grub nicht die korrekte Zieladresse für den remote-logging-service an den kernel übergibt. Hast Du einen Tipp für mich, wie man auf dem UCS an den Grub-defaults für die Clients schrauben kann?

Liebe Grüße
Christian


#5

Hallo,

ich habe mich zuerst zwar auch durch die Konfiguration vom rsyslogd auf dem Client gewühlt (in /etc/rsyslogd.d/100-ucc.conf), habe dann aber gesehen, dass die Parameter in der Dokumentation stehen:
5.7. Remote logging.

Viele Grüße,
Dirk Ahrnke


#6

Hallo,

diesen Eintrag hatte ich auch gesehen. Ich hatte aber gedacht, dass ucc/pxe nur greift, wenn die Clients ausgerollt werden. Wenn dem so wäre, würde ich es via ansible versuchen.

Liebe Grüße
Christian


#7

Im UCC selbst gibt es auch eine UCS-Variable “grub/append”. Bei mir steht da auch “syslog” und “syslogserver”. Die gesetzten Werte beeinflussen direkt die erwähnte Konfigurationsdatei.
Ich vermute, dass die Werte aus “ucc/pxe/append” während Installation oder Update nach “grub/append” kopiert werden.


#8

Bei mir ist in grup/append nichts enthalten. Ich werde es mal am Freitag ausprobieren, wenn ich wieder vor Ort bin.
Danke!