Questions regarding Backup DC and restore of an UCS system

we recently migrated our UCS DC-Master to new hardware. We had some trouble with the new RAID-Controller (Intel) and ended up with a lot of garbage files. We had to set back the system to the date of migration about one month back. Also since the LDAP was down during this time our coworkers didn’t have access to anything in the network. Therefore we decided to use the old hardware and set up a Backup DC.

Installation of the new UCS system run into problems with the network settings.The master couldn’t be found by the installer under the (correct) DNS IP address ( We continued to install nonetheless and tried to join later with univention-join. The problem with the master persisted, so we could only trigger the join-script by adding the parameter -dcname master.domain.local. We had to fix some file privileges (they were only accessable by root not by the DC backup group) but eventually the join was completed successfully.

When we ran a backup/restore test however, the backup DC didn’t do anything to keep the domain working.
We found this article and added the settings accordingly but still no luck. (Shouldn’t these settings be done by the join-scripts?) Are we missing something?

Additional observations:
We tried to use a replica DC installation instead of backup DC which had the same problem at first with joining the domain. However, after ldap/server/name on the replica DC was set to master.domain.local (instead of replica.domain.local) the additional -dcname for univention-join wasn’t needed. It wouldn’t work the same with the backup DC (i.e. even setting ldap/server/name to master the join script would not find the dc).
On the local shell login the name and IP of the backup/replica DC was mentioned as primary domain controller.
The command host -t SRV _domaincontroller_master._tcp.master.domain.local results in NXDOMAIN. Even though the entry on the DNS/master seems correct to us.
(The server overview from the webinterface leads to an 404 on the replica node.)

Are the DNS/master problems maybe the root cause of the backup/replica not working correctly? Or are we overlooking another important step in the setup?

Another note on the restore: We used this article from the univention wiki to backup and restore. It recommends to restore /etc completely (if backuped completely which we did). Afterwards the system booted in read-only mode and was unusable. We think it might be a problem due to the UUIDs in /etc/fstab that may change with new hardware. Is this procedure really correct?