Question about Upgrade from UCS-4 to UCS5

I have made extensive test on UCS 5 and UCS-5 looks ready for prod, at least for new installations. but … I am a bit surprised to see an upgrade proposition in my ucs-4 servers, because UCS-5 is absolutely not ready to replace existing UCS-4 regarding app availability.

Or should you noisily alert all UCS upgrade about compatibility in the app center, or regarding installed app in previous UCS-4.

Some essential APP have comme later like NextCloud, but there is essential app like Nagios, Kopano, openExchange,

I have made a diff regarding app availability between ucs4 and ucs5 and I feel scary by the lost of all these app:
< agorumcore-pro
< apple-school-manager
< audriga-groupware-migration
< bareos
< bitwarden
< bluespice
< collabora
< collabora-online
< digitec-suitecrm
< filewave
< gitlab
< google-apps
< guacamole
< horde
< iku-av-mail
< itslearning
< jenkins
< kde
< kopano-core
< kopano-meet
< kopano-webapp
< kopano-webmeetings
< kvm
< letsencrypt
< m23
< mobydick
< nagios
< office365
< open-xchange-guard
< open-xchange-text
< openid-connect-provider
< openproject
< openvpn4ucs
< opsi
< ox-connector
< oxseforucs
< printquota
< privacyidea-radius
< privacyidea-saml
< prometheus
< prometheus-node-exporter
< relution
< rocketchat
< sep-sesam
< sep-sesam-cli
< stashcat
< ucsschool
< ucsschool-id-connector
< ucsschool-kelvin-rest-api
< ucsschool-veyon-proxy
< uvmm
< webuntis
< webweaver
< xrdp
< z-push-kopano
< zimbra
< zuludesk

even in dev-test-mode lots are not installable. impossible for me to install letsencrypt for instance. So I am really not sure if installed UCS-4 server are ready to migrate with this lack of apps.

Could you please provide clear instruction on what are optimal conditions for migrating UCS-4 to UCS-5


I tried to upgrade my test UCS4 VM to UCS5 and it failed with only the self service and ucs mail components installed. I had to manually remove some things to even get it to finish the upgrade, but after it was done the self service components were not installed properly and I haven’t been able to fix it by manually uninstalling the packages either.

Right now I would not recommend the upgrade for anyone personally. It seems to me that a new install with a migration might be the only viable option currently, and that’s assuming you are only using UCS 5 supported apps on your existing server.

I have an image of my test UCS4 server so I plan on testing the upgrade again after some further refinement is done on UCS 5. Hopefully the upgrade issues can be worked out.

1 Like

But < letsencrypt is working with UCS 5.0 have tested that.

letsencrypt is present in the app center, but I can not reach install page. every time I try to install it, its ends in a non-responsive page. (app center page with central gif rolling, with no response, I can’t even not reach install page). Others packages install successfully, or at least I can reach the install page. I have made 2 distinct install of ucs-5 and see the same problem with letsencrypt.

strange for Letscrypt is in UCS5.0:

Try install USC 4.4 on an virtuell server then uppgrade to UCS5.0 that i doing and letscrypt is working after that

if its supposed to works, can someone indicate me a way to troubleshoot what happening to my installation ?