Qnap NAS as Samba AD Domain meber stoped working


for 2 years now my QNAP NAS 869 was a member of my UCS Domain. Some times (less then 1 time a month) i got a message from the NAS “Domain join failed” but all things worked as expected. A month ago i did a firmware Update and restarted the UCS and the NAS. One or two days later the users can’t access their folders on the NAS and the Domain failure message become permanet. So tried to leave the domain and re join. Ping from QNAP to UCS is possible and the time settings are the same. But i can’t join again. I deleted the nas in the UCS Domain but this can’t help to join again. After that i wrote to the QNAP Support. After sending my dumpfile from the QNAP to the supporter i got the answer “sorry no samba/linux AD is supported” - ticked closed.

Can you tell me how to search for any hints to fix this issue?

Kind regars


I forgot to write that Windows computers are able to leave and join the domain without a problem.

This occurred after the firmware update? Have you considered rolling back to the prior firmware on the NAS?

BTW, I have had nothing but troubles with the one QNAP NAS at a client’s location. For all the other clients with small offices I use Synology and run UCS AD services as a VM - with very few issues.

If you’ve had this QNAP unit for a few years, maybe it’s a good excuse to transition to a new vendor?

Hi aggie,

the FW Update was some days ago.

You are right it would be the easyest way to change from QNAP to Synology. In a other case the support of Qnap wrote to me that the NAS is to old and they won’t help here. So i’m not happy with the support.

It is a pity that i bought this nas just 2or3 years ago and it was no cheap stuff.