QEMU, VIRTIO and HP printer management software

virtualization

#1

I have just installed seven new HP printers that will be managed by HP through their Jet advantage software.
I had created a Windows 2008R2 server to act as the print server and it was running on UCS 4.1.3-239 using
QEMU and managed by UVMM and I’d installed VIRTIO drivers for the hard drives (a pretty standard install).
I then started installing the HP software but during its prerequisite checks it said I couldn’t install it on the
C: drive because it wasn’t an internal system drive, it saw it as a network drive.


I tried creating a new drive image as D: drive (RAW and QCOW2) but nothing worked.
In the end I used Sysinternals ‘disk2vhd’ to grab a copy of the qemu image and copied it to a hyper-V server.
The software installed without a glitch.

I assume it is the VIRTIO drivers that are the problem. I would like to use the latest version of QEMU on UCS
but there are obviously restrictions to this which is a shame, I don’t think it would solve the problem
but it would just be nice to have a current QEMU version.


#2

Hey,

are you sure it’s related to the drive using VirtIO? Meaning have you tried to install the same software in a VM that uses the regular IDE mode?

Windows knows one specific API function that a program can use to determine what kind of drive a drive letter refers to: GetDriveType(). I’ve wrapped it into a small program that you can download and run in order to see what your Windows VM actually reports for C:. You need to run it from cmd.exe like this: “get_drive_type C:” (replace C:\ with other drive letters as appropriate).

Of course it’s possible that the HP software uses some other kind of obscure method for determining the drive type…

Kind regards,
mosu