Q&A: Can I Run UCS as a Hyper-V Gen2 Virtual Machine?

Question

Can I install and run UCS as Microsoft Hyper-V Gen2?
I can install but after the reboot I am getting a grub prompt as shown in this screenshot.
ucsboot

Answer

As of now (UCS 4.3) we only support the installation of UCS in a Hyper-V Gen1 type machines.

When using our Gen1 image you will see the following screen:
image001

There is a bug open regarding this and you might use a workaround as documented in this article.