Probleme nach Update auf 3.1

german

#1

Hallo zusammen,

nach dem Update auf 3.1 komme ich leider nicht mehr in die Management-Oberfläche, der Screen nach dem Login bleibt immer auf 96%, “Loading modules”.
Reboot hilft auch nicht.

Hat jemand ein Idee voran es liegen kann?

Danke und Gruß,
Yasmin K.

P.S. Update war erfolgreich



#2

[quote=“yasmin_k”]Hallo zusammen,

nach dem Update auf 3.1 komme ich leider nicht mehr in die Management-Oberfläche, der Screen nach dem Login bleibt immer auf 96%, “Loading modules”.
Reboot hilft auch nicht.

Hat jemand ein Idee voran es liegen kann?

Danke und Gruß,
Yasmin K.

P.S. Update war erfolgreich[/quote]

UPDATE: hab’t rausgefunden, dass über HTTPS funktioniert. Nur über HTTP geht’s nicht.


#3

[quote=“yasmin_k”][quote=“yasmin_k”]Hallo zusammen,

nach dem Update auf 3.1 komme ich leider nicht mehr in die Management-Oberfläche, der Screen nach dem Login bleibt immer auf 96%, “Loading modules”.
Reboot hilft auch nicht.

Hat jemand ein Idee voran es liegen kann?

Danke und Gruß,
Yasmin K.

P.S. Update war erfolgreich[/quote]

UPDATE: hab’s rausgefunden, dass über HTTPS funktioniert. Nur über HTTP geht’s nicht.[/quote]

UPDATE2: eine Anmeldung über HTTPS ging, die zweite nicht mehr… :frowning:
Also, Stand ist: ich komme nicht mehr in die Management-Oberfläche.


#4

Hallo,

haben Sie die Logdatei /var/log/univention/updater.log bereits auf Auffälligkeiten geprüft?
Handelt es sich bei versuchten Logins stets um das Online Update Modul, bei welchem das Laden der UMC “stehenbleibt”?

Mit freundlichen Grüßen,
Tim Petersen


#5

Hallo,

ja, allerdings finde ich nichts auffälliges.

[code]root@ucs:/var/log/univention# more updater.log

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: found
Please rerun command without --check argument to install.
16.12.12 16:56:48.995 DEBUG_INIT
**** Starting univention-updater with parameter=[’/usr/share/univention-updater/univention-updater’, ‘net’, ‘–silent’,
‘–check’]
—>DBG:update_available(mode=net, cdrom_mount_point=/cdrom, iso=None)
Checking network repository
System is up to date
16.12.12 17:06:52.973 DEBUG_INIT
**** Starting univention-updater with parameter=[’/usr/share/univention-updater/univention-updater’, ‘net’, ‘–silent’,
‘–check’]
—>DBG:update_available(mode=net, cdrom_mount_point=/cdrom, iso=None)
Checking network repository
System is up to date

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none

Starting univention-upgrade. Current UCS version is 3.1-0 errata0

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none
root@ucs:/var/log/univention# [/code]

Ja, es handelt sich die ganze Zeit um das Online Update Modul. Wie erwähnt, nach dem Update konnte ich mich einmal über HTTPS einloggen, danach ging’s auch HTTP auch nicht mehr.

Viele Grüße,
Yasmin Keller


#6

Hallo,

gern würde ich mir das Verhalten einmal näher ansehen.
Bitte erstellen Sie hierzu ein nach SDB-Artikel #1174 erstelltes Univention-Support-Info Archiv und lassen uns dieses zukommen. Hierzu können Sie wie im Artikel beschrieben upload.univention.de verwenden - den generierten Dateinamen senden Sie uns zur Zuordnung anschließend bitte zu.

Mit freundlichen Grüßen,
Tim Petersen


#7

Hallo Herr Petersen,

ist schon passiert:

Ich habe die Dateien auf Ihren Server hochgeladen, die Dateinamen lauten:

upload_1SnQ9X.bz2
und
upload_QwVYzb.bin

Die zweite Datei ist die .gpg Datei.

Viele Grüße udn besten Dank,
Yasmin Keller


#8

Hallo,

bei der Durchsicht der Logdateien ist aufgefallen, dass die initiale Installation fehlschlug:

The following NEW packages will be installed: ucs-ct-edition 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/5360 B of archives. After this operation, 81.9 kB of additional disk space will be used. WARNING: The following packages cannot be authenticated! ucs-ct-edition Failed to fetch file:/sourcedevice/packages/./ucs-ct-edition_1.0.4-3.19.201211021037_all.deb Hash Sum mismatch Authentication warning overridden. E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? yes: standard output: Broken pipe yes: write error

Aufgrund der Fehlermeldung “Hash Sum mismatch” und der Tatsache, dass Sie das System als virtualisierte Instanz verwenden, gehe ich hier stark von einem defekt generierten ISO-File aus.
Das aktuelle Symptom ist hier als Folgefehler zu verstehen. Kurz zum technischen Hintergrund: Das Update auf UCS 3.1 steht aufgrund einiger kleinerer Anpassungen erst in naher Zukunft für die c’t Edition zur Verfügung und wird momentan normalerweise vom UCS-Updater geblockt. Dies konnte auf diesem inkosistenten System nicht passieren, da die c’t Komponente initial nicht korrekt installiert und somit nicht erkannt werden konnte. Ein Hash Sum mismatch deutet auf defekte Pakete hin, daher der Hinweis auf ein eventuell defektes ISO und /oder DVD(-Laufwerk).

Mit freundlichen Grüßen,
Tim Petersen


#9

Hallo Herr Petersen,

ok, verstehe.

Was soll ich nun tun?
Muss ich UCS erneut installieren und die Updates noch nicht ausführen (die werden allerdings in der Managment GUI angezeigt)?

Viele Grüße,
Yasmin Keller


#10

Hallo Frau Keller,

auf einem korrekt installierten UCS 3.0 c’t edition sollte kein verfügbares Update auf UCS 3.1 in der UMC angezeigt werden.
Haben Sie das System mit einem selbst erstellten ISO installiert? In diesem Fall sollten Sie das Generieren wiederholen und die Installation mit einem funktionstüchtigen ISO wiederholen. Eventuell können Sie ja auch alternativ das lokale DVD-Laufwerk zu Ihrer Virtualisierungslösung durchreichen?

In jedem Fall müsste das System selbstverständlich neu installiert werden, da es wie gesagt nicht erfolgreich und vollständig installiert wurde/werden konnte.

Mit freundlichen Grüßen,
Tim Petersen


#11

Hallo Herr Petersen,

alles klar, ich werde es neu installieren.

Nein, ich habe die c’ t DVD benutzt, das Original.

Mit freundlichen Grüßen,
Yasmin Keller


#12

Hallo,

bevor Sie das System erneut neu installieren, sollten Sie verifizieren, ob Ihre DVD “in Ordnung” ist - die Fehlerquelle der korrupten Pakete kann hier entweder von einer defekten DVD oder einem defekten Laufwerk ausgehen.

Hierzu prüfen Sie bitte die MD5-Summe der DVD - diese sollte 127e80e95f6598eefc332a223db717a1 sein.

Mit einer entsprechenden EMail an leserservice@heise.de sollten Sie eine eventuelle defekte DVD problemlos tauschen lassen können.

Mit freundlichen Grüßen,
Tim Petersen


#13

Hallo,

ich habe UCS von derselben DVD reinstalliert, jetzt passt alles.

Vielen Dank für Ihre Hilfe.

Mit freundlichen Grüßen,
Yasmin Keller