Probleme mit ClamAV

german

#1

Hallo,
seit gestern abend lässt sich auf einem UCS 2.2-4-4 (mit OX6) der ClamAV nicht mehr starten (auf 2 OX6-Installationen). Es kommt zur Fehlermeldung:

LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON’T PANIC! Read clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see clamav.net/download (length: 169)
LibClamAV Error: Problem parsing database at line 742
LibClamAV Error: Can’t load daily.ndb: Malformed database
LibClamAV Error: cli_tgzload: Invalid size in header
LibClamAV Error: Can’t load /var/lib/clamav/daily.cld: Malformed database
ERROR: Malformed database
failed!

Im Maillog tauchen auch dann diverse Fehlermeldungen in der Art

Apr 16 11:00:06 mailserver amavis[2193]: (02193-01-7) (!!) TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: Clam Antivirus-clamd av-scanner FAILED: Too many retries to talk to /var/run/clamav/clamd.ctl (Can’t connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory) at (eval 44) line 268.

auf. Diverse Postings hier in dem Forum und die entsprechenden Supporteinträge waren nicht hilfreich. Ich vermute mal, dass der ClamAV auf die Version 0.95 oder besser 0,96 aktualisiert werden muss (siehe tinyurl.com/yyzb4tf).
Ein “univention-updater net” hat leider die ClamAV-Verdion nicht mit aktualisiert. Wie kann ich den ClamAV aktualisieren auf eine funktionierende Version? Ich werde momentan mich erstmal gezwungen sehen, den ClamAV komplett abzuschalten, damit Mail überhaupt wieder geht.

Danke für jede Hilfe,
Ralf


#2

Ich habe noch folgenden Hinweis dazu gefunden im OX-Forum:

open-xchange.com/forum/showt … hp?p=17547

ClamAV hat seit gestern (15.4.2010) also die alten ClamAV-Versionen wie vermutet per Pattern-Update deaktiviert. Und OX wartet auf UCS, das hier ein Fix kommt …


#3

Es ist ewtas mühsam sich hier durch verschiedene Foren durchzuwühlen, aber hier scheint die Lösung zu sein: open-xchange.com/forum/showthread.php?t=4631


#4

Hallo,

für UCS ohne OX ist dieser Fall in unserer Supportdatenbank unter sdb.univention.de/1129 beschrieben.

Mit freundlichen Grüßen
Janis Meybohm


#5

Hallo ich muss ein Problem melden. Bis heute ging alles wunderbar. Nur muss ich feststellen, das ich aufeinmal keine emails mehr empfangen habe. Habe deswegen Test Emails geschickt die aber nicht durch kommen. Habe das System neu gestartet und habe diesen Fehler entdeckt:

[code]LibClamAV Warning: ************************************************** *********
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON’T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ************************************************** ********

LibClamAV Error: cli_hex2str(): Malformed hexstring: eh0668[4-4]c3 (length: 13)
LibClamAV Error: Problem pasring database at line 875
LibClamAV Error: Cant`t load daily.ndb; Mailformed database
LibClamAV Error: cli:tgzload: Can’t load daily.ndb
LibClamAV Error: Can’t load /var/lib/clamav/daily.cld: Mailformed database
ERROR: Malformed database
failed[/code]

Hab es wieder zum laufen gekriegt. Da bin ich wohl nicht der einige gewesen. Aber viele berrichten von 2010 davon. Wir haben es jetzt 2011.

Wie kann sowas passieren? Mach mir wirklich sorgen, weil einige wichtige Emails kommen könnten und ich Sie nicht empfangen kann, weil das System Sie nicht weiter durch reicht…

Bitte um Antwort und im Hilfe…


#6

Hallo,

das Problem wurde vermutlich durch ein Problem mit einem Signaturupdate von gestern Abend (ca. 22:25 Uhr) ausgelöst. Details und weitere Hinweise finden Sie im Artikel Probleme mit ClamAV durch Signatur-Update unserer Supportdatenbank.

Mit freundlichen Grüßen
Janis Meybohm